Closed Bug 469997 Opened 13 years ago Closed 13 years ago

Tabs persist into private browsing mode when browser.privatebrowsing.autostart is toggled to true

Categories

(Firefox :: Private Browsing, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 467565

People

(Reporter: u88484, Unassigned)

Details

(Keywords: ue)

When browser.privatebrowsing.autostart is toggled to true, whatever tabs were open the next close of Firefox (the time before your next start into PB mode) will open each time Firefox is started with browser.privatebrowsing.autostart;true.

STR:
1) Open in separate tabs www.yahoo.com, www.google.com, www.cnn.com
2) Go to about:config
3) Toggle 'browser.privatebrowsing.autostart' to true
4) Close about:config tab
5) Close Firefox
6) Open Firefox (which will now be in autostart private browsing mode)
7) Note that the tabs in step 1 are opened along with Firefox
8) Click the tab close button on the google and cnn tabs
9) Repeat steps 5 through 7.

You can not get rid of those tabs unless you toggle 'browser.privatebrowsing.autostart' to false, restart Firefox and close those tabs.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 467565
Mass moving of all Firefox::General private browsing bugs to Firefox::Private Browsing.
Component: General → Private Browsing
QA Contact: general → private.browsing
You need to log in before you can comment on or make changes to this bug.