TM: JIT of chrome locks up firefox at 100% CPU when debugging in Firebug

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: bugs, Unassigned)

Tracking

1.9.1 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [firebug-p3], URL)

Attachments

(1 attachment)

409 bytes, application/xhtml+xml
Details
(Reporter)

Description

10 years ago
Reporting for Firebug 1.3X.0b6 - will test in 1.4 next.
http://getfirebug.com/releases/firebug/1.3X/

1) Install latest 1.3X
2) Load http://m8y.org/js/test21.xhtml
3) Open firebug, enable script debugging, open script pane (I found script pane in 1.3X is blank unless I click on CSS pane first)
4) set a breakpoint at (function() { var foo=5; })();
5) click on "testing" button
6) Click on "step into" (arrow or F11 inside Firebug pane) repeatedly until Firefox locks up

Repeatedly reproducible.
I imagine it would work too if I add the page as an attachment, which I will do after testing 1.4
Just wanted to write this up while I had 1.3 still on this profile.
(Reporter)

Comment 1

10 years ago
Created attachment 353480 [details]
Testcase
(Reporter)

Comment 2

10 years ago
Unable to test Firebug 1.4 - seems to not function on my latest trunk (blank pane/window).

Oh, and just to be clear, reproducing this requires JIT of chrome to be enabled, without that, it steps through fine.
(Reporter)

Comment 3

10 years ago
Verified, still locks up when using the attachment (not surprising, but hey).
I'm not sure how valid this bug is or if enabling chrome JIT is supported in Firefox. Firebug 1.4 is currently in an alpha state and shouldn't be considered ready for prime-time, though a crasher is probably worth looking into.
Whiteboard: [firebug-p3]
Version: unspecified → 1.9.1 Branch
also, please include your Firefox build id from the About dialog.
(Reporter)

Comment 6

10 years ago
Latest trunk.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20081217 Minefield/3.2a1pre

As for who is at fault here, tricky.  But since it locks up entire browser and *only* does it if JIT of chrome is enabled, I'm leaning towards JIT being at fault.  After all, isn't the point of JIT is that it should be transparent to the JS?

As for reporting, I asked in dev channel first since I wasn't sure whether it was worthwhile, gavin said I should go ahead and report it.
yeah, no question. Just trying to work through murky depths of where this bug could end up. Seems likely that it's a JS bug. We'll see what comes up. Thanks for the report!
Blocks: 453668
(Reporter)

Comment 8

9 years ago
No longer able to reproduce in Firebug 1.4 and 1.3 is long gone.
Besides, no one really had any interest in it :).

Going to go with "fixed"
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.