After clicking Display Images, can't use space bar to scroll Preview Pane

RESOLVED DUPLICATE of bug 308875

Status

Thunderbird
Mail Window Front End
--
minor
RESOLVED DUPLICATE of bug 308875
9 years ago
9 years ago

People

(Reporter: Hadar Pedhazur, Unassigned)

Tracking

Trunk
x86
Windows Vista

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4
Build Identifier: 3.0b1

To my knowledge, this has been an issue since the 2.0 days, still exists in TB3. I have only tested it in Windows, but both XP and Vista.

When a message comes in with images in it, I have TB not display them by default (I love that option).

However, when I click on "Display Images" (in both TB2 and TB3), I can't hit the space bar to scroll through the message in the Preview Pane, until I click back on the message in the list view above the Preview Pane. Then the space bar will page through the message.

Once I click on the Display Images button, I'm in "no man's land", and hitting the space bar pages down for a second, and then jerks the message right back up to the top. It's very annoying, though easy to work around...


Reproducible: Always

Steps to Reproduce:
1. Get a message with Images in it (having turned off auto-display)
2. Click on the Display Images button.
3. Press the Space Bar (to try and scroll the message in the Preview Pane)
Actual Results:  
The message will scroll for a second, and then snap right back to the top. You have to first click on the message line in the message list above the Preview Pane in order to reset something internal. Then you can hit the Space Bar to scroll.

Expected Results:  
The message should just scroll correctly, immediately, when hitting the Space Bar, even if the Display Images button was just clicked.
(Reporter)

Comment 1

9 years ago
I should add that after clicking Display Images, if you click directly in the body of the email, you can hit the Space Bar to scroll down as well. The point is that this should work immediately after hitting the Display Images button, and not require the extra mouse movement and click.
Confirmed on Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b3pre) Gecko/20081218 Shredder/3.0b2pre.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: DUPEME
Version: unspecified → Trunk
Sorry, this looks like Bug 308875.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
Duplicate of bug: 308875
You need to log in before you can comment on or make changes to this bug.