fix layout-debug chrome registration

RESOLVED FIXED in mozilla1.9.1b3

Status

()

RESOLVED FIXED
10 years ago
2 months ago

People

(Reporter: dbaron, Assigned: dbaron)

Tracking

({fixed1.9.1})

Trunk
mozilla1.9.1b3
fixed1.9.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 353514 [details] [diff] [review]
patch

So a few months ago I had to write a patch in my tree in order to get the layout-debug tool to work again.  I didn't file a bug at the time because I wanted to figure out why it had regressed.

I still haven't figured it out for sure, but my current theory is that it is a regression from bug 439050.

In any case, here's the patch.  Requesting Axel's review in case he can tell me (1) whether these changes seem correct and (2) whether the need for them is an expected result of bug 439050.
Attachment #353514 - Flags: review?(l10n)

Comment 1

10 years ago
Comment on attachment 353514 [details] [diff] [review]
patch

Actually, yes, that's expected. contents.rdf has been deprecated for a while and got removed.

r=me.

I updated https://developer.mozilla.org/En/JAR_Manifests to reflect that.
Attachment #353514 - Flags: review?(l10n) → review-

Comment 2

10 years ago
Comment on attachment 353514 [details] [diff] [review]
patch

err, being able to read helps. r+
Attachment #353514 - Flags: review- → review+
(Assignee)

Comment 3

10 years ago
Fixed: http://hg.mozilla.org/mozilla-central/rev/38440caec347
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.2a1
(Assignee)

Comment 4

10 years ago
Fixed on 1.9.1: http://hg.mozilla.org/releases/mozilla-1.9.1/rev/7578683f4dc0
Keywords: fixed1.9.1
Target Milestone: mozilla1.9.2a1 → mozilla1.9.1b3

Updated

9 years ago
Depends on: 510827

Updated

2 months ago
Product: Core → Core Graveyard
Component: Layout: Misc Code → Layout
Product: Core Graveyard → Core
You need to log in before you can comment on or make changes to this bug.