If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Implement automatic hiding of discount image and page after 12/26/09 11:59pm

VERIFIED FIXED in 2.0

Status

Websites
communitystore.mozilla.org
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: rdoherty, Assigned: rdoherty)

Tracking

unspecified

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

9 years ago
Forgot about this. According to the page, the 20% discount ends 12/26 at 11:59pm PST. We need to put in some code to hide the discount image and 404 the page after that.
(Assignee)

Comment 1

9 years ago
Created attachment 353536 [details] [diff] [review]
Date code
Attachment #353536 - Flags: review?(buchanae)
Duplicate of this bug: 470094

Comment 3

9 years ago
sorry about that !
(Assignee)

Updated

9 years ago
Attachment #353536 - Flags: review?(buchanae)
(Assignee)

Comment 4

9 years ago
Created attachment 353538 [details] [diff] [review]
Date code with proper year

Proper patch.

Stephen, I can work with you to QA this because we can't time travel yet :)
Attachment #353536 - Attachment is obsolete: true
Attachment #353538 - Flags: review?(buchanae)
Attachment #353538 - Flags: review?(buchanae) → review+
Comment on attachment 353538 [details] [diff] [review]
Date code with proper year

looks OK to me
(Assignee)

Comment 6

9 years ago
r21036

This may still show up after 2 hours, but not more than 2 hours after 11:59pm due to Netscaler caching. This shouldn't be a huge issue because we do have the date for the discount on the page.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Comment 7

9 years ago
Yup, no worries.  Sounds good to me.
http://communitystore.mozilla.org/discount is a 404, and the image is no longer on the homepage.

Verified FIXED :-)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.