If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Cross compiling x86-64 -> x86 broken

RESOLVED FIXED

Status

()

Core
Build Config
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: Benjamin Smedberg, Assigned: Benjamin Smedberg)

Tracking

({fixed1.9.1})

unspecified
x86
Linux
fixed1.9.1
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9.1 +

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

9 years ago
I use the following script to cross compile x86-64 -> x86 on Linux:

http://hg.mozilla.org/users/bsmedberg_mozilla.com/configure-scripts/file/1e492a582e34/configure-m32

This has broken sometime recently: jsautocfg.h has host values for everything, instead of target values, in particular:

#define JS_BYTES_PER_WORD   8L

This manifests itself as a build error:
../../../src/js/src/jsatom.h:69: error: size of array ‘arg’ is negative

Which is on the line:

JS_STATIC_ASSERT(sizeof(JSAtom *) == JS_BYTES_PER_WORD);
Flags: blocking1.9.1?
Duplicate of this bug: 471059
Blocks: 468509

Comment 2

9 years ago
Is there an understood ideal way to fix this? If so, can someone describe what needs to happen?

Comment 3

9 years ago
I'm not sure this should block -- why?

Jim, could you take a look here?
Assignee: nobody → jim
(Assignee)

Comment 4

9 years ago
It's a fairly recent regression, and makes it difficult for me personally to do static-checking of JIT builds (since we don't have JIT on x86-64). But I think it's fairly well in hand now that the configured uintN types have landed.

Comment 5

9 years ago
Does this checkin http://hg.mozilla.org/mozilla-central/rev/525e42406396 interfere with this bug? I've tested to build a x86_64 build on Mac OS X after this checkin and now the contents of jsautocfg.h looks different than before.
Fixed by bug 269538. I'm now able to build js/src standalone by doing:
CC="gcc -arch x86_64" CXX="g++ -arch x86_64" AR=ar ../mozilla-central/js/src/configure --target=x86_64-apple-darwin
(not sure when that requirement for AR crept in.)
Assignee: jim → benjamin
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Depends on: 269538
Resolution: --- → FIXED

Comment 7

9 years ago
Hm, Bug bug 269538 is no reopened and the patch is backed out due to Windows TUnit bustage...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

9 years ago
Flags: blocking1.9.1? → blocking1.9.1+
(Assignee)

Comment 8

9 years ago
Fixed on trunk and branch by bug 269538
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago9 years ago
Keywords: fixed1.9.1
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.