Javascript replace inner text not working as expected in Camino 1.6.6

RESOLVED INVALID

Status

Camino Graveyard
General
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: T.K.Egan, Unassigned)

Tracking

Details

(Whiteboard: [CLOSEME - 2/1], URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.8.1.19) Gecko/20081212 Camino/1.6.6 (like Firefox/2.0.0.19)
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.8.1.19) Gecko/20081212 Camino/1.6.6 (like Firefox/2.0.0.19)

Using Camino 1.6.6 PPC English at the above site causes unexpected behavior when the user clicks an arrow to go to next or previous month. The calendar table disappears and the new table is displayed below the space where the previous table was displayed. This is not the behaviour exhibited by 1.6.5, OmniWeb/Safari or Firefox 3.0.4

Reproducible: Always

Steps to Reproduce:
1.Click arrow on site to go to next or previous month
2.
3.
Actual Results:  
space is left empty as if the replace inner text is inserted below the previous content and the space occupied by the former content is never freed.

Expected Results:  
the blank space should have been "freed" and the new content ought to replace the old without adding extra white space.

Just updated to 1.6.6 manually by downloading the dmg and overwriting 1.6.5 after software update failed during the install and relaunch phase.
Seems to work OK in Firefox 3.0.5 too. Will try 2.0.0.19 next.
A 20081202 build of Firefox 2.0.0.20pre seems to work OK on that site. Really doesn't seem like a content problem should be Camino-only. How much "like" Firefox/2.0.0.19 is Camino?
This works for me on 1.6.6 as well, both my normal profile and and a fresh profile, and in Firefox 2.0.0.19 with a dirty profile.  

(The only problem I saw is the the arrows aren't clickable when you've changed certain font sizes, since the z-index of the UL for the About/Photos/etc. interferes when those areas overlap.  But that's not comment 0, anyway.)

T.K., does the site work properly for you with a fresh profile?  You can use http://pimpmycamino.com/parts/troubleshoot-camino to help automate testing with
a fresh profile.
T.K., can you please respond to comment 3?
Whiteboard: [CLOSEME - 2/1]
(Reporter)

Comment 5

10 years ago
Sorry, Got deep into another project. Anyways when I tried today with a fresh profile things are cleared up. Thanks Smokey.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.