after search in bookmark sidebar, properties dialogue is incomplete (tag+folder missing)

RESOLVED DUPLICATE of bug 469416

Status

()

RESOLVED DUPLICATE of bug 469416
10 years ago
10 years ago

People

(Reporter: mozilla, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5

In bookmark sidebar, after a search, one cannot see neither tags nor containing folder of a search result, also not in "properties" which SHALL present IMHO all bookmark fields. Hence, it is impossible to a) find and b) create siblings (e.g. a newly found firefox extension shall be files as all other extensions) by the means of the bookmark sidebar. 

About workarounds:

Finding siblings within same tag(s) is possible in organize bookmarks, but not siblings within same folder => completely impossible. This was possible in NS4 (standard function, see  Bug 171575) and FF 2 (using extension Locate Me). 

Creation of a sibling possible in organize bookmarks by copying the original, pasting it and editing location & name & keyword & description => not a convenient workflow. 

IMHO, "properties" of a bookmark shall be displayed in all places one can access them, not only a few.

Reproducible: Always

Steps to Reproduce:
1. CTRL+B to optn bookmark sidebar
2. type something in search bar (eg "wiki")
3. in your results, bookmark "wikipedia" may appear. 

Actual Results:  
4a. Right click and call "properties". You only see some, not all property fields.
4b. Try to create a bookmark "wikipedia DE" with similar filing (tags+folder) as "wikipedia".

Expected Results:  
4a. Right click and call "properties". You see all property fields (no filtered view). Tags are displayed like in "Library" (comma seperated with optional listing) and folder is clickable full path to bookmark; click opens folder in Library.
4b. Create a bookmark "wikipedia DE" with similar filing (tags+folder) as "wikipedia" is easy, just put tags into clipboard, click on folder, drop favicon from awesome bar to folder in library, and paste tags.
(Reporter)

Comment 1

10 years ago
Bug 405549 is about showing tags in bookmarks sidebar directly, not about editing a bookmark.
(Reporter)

Updated

10 years ago
Version: unspecified → 3.0 Branch

Comment 2

10 years ago
you should only file a single request per bug

Bug 405549 is about showing tags in bookmarks sidebar directly
Bug 411261 has added tagging ui to properties
Bug 469421 is about adding a folder column to Library (but most likely will cover sidebar too)
to create a bookmark similar to another one you can CTRL+DRAG the bookmark.

you should file your missing requests as new bugs, but only one per bug please.
Invalid because multiple requests in one report.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

10 years ago
Hi Marco, I don't see multiple bugs/requests, but only that "properties" shall show all properties and in a usable manner. In "Expected Results", 4a is a UI suggestion and 4b is merely a suggested user workflow, so only 1 place where code has to be altered. Please point out the "multiple requests" - I just don't see them. /Georg

Comment 4

10 years ago
Sorry request was not much clear, hwv what you ask is adding Tags and Folder to "properties" dialog, tags are already added in 3.1, for Folder you should refer to bug 469416, so effectively this is a dupe of that.
Resolution: INVALID → DUPLICATE
Duplicate of bug: 469416
You need to log in before you can comment on or make changes to this bug.