Ctrl-K kills unexpected part in message composing window.

RESOLVED DUPLICATE of bug 469482

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 469482
9 years ago
9 years ago

People

(Reporter: Satomi Yoneki, Unassigned)

Tracking

Trunk
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-GB; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-GB; rv:1.9.1b3pre) Gecko/20081204 Thunderbird/3.0b1

Ctrl-K kills unexpected part (or none) of a line in message composing window.

It is expected to kill toward the end of line and the shortcut worked so in Thunderbird 2.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Can you please give a few more specifics. Also, try in Safe Mode. The steps to reproduce are important and not just for fun.
Are you seeing Bug 462700?
(Reporter)

Comment 3

9 years ago
I saw Bug 462700 before filing this. The report says it works as expected when the cursor is in a line on Linux with a gtk theme. On Mac OS X, Ctrl-K does not work even when the cursor is in the middle of a line.

Here are some examples of Ctrl-K in safe-mode.

Type "Lorem ipsum dolor sit amet," and place the cursor just after "ipsum".
Press Ctrl-K. It kills "orem ipsum" leaving "L dolor sit amet,".

Type "Lorem ipsum dolor sit amet," and place the cursor after any space.
Press Ctrl-K, and it kills the space before the cursor.

Type "我が輩は猫である。名前はまだない。" and place the cursor between "。" and "名".
Press Ctrl-K, and it kills "は猫である。" leaving "我が輩名前はまだない。"
(Reporter)

Updated

9 years ago
Hardware: PowerPC → x86
Version: unspecified → Trunk
Have you tried in Safe Mode?
(Reporter)

Comment 5

9 years ago
Yes, the examples above are all in Thundirbird safe mode.

Comment 6

9 years ago
Does bug 469482 sound like your bug?
(Reporter)

Comment 7

9 years ago
Yes, sounds like the same bug.

Comment 8

9 years ago
Can you test beta2 and see if that fixes anything? Reply in the other bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 469482
You need to log in before you can comment on or make changes to this bug.