Closed Bug 470208 Opened 13 years ago Closed 13 years ago

wrong call in log4moz.js

Categories

(Cloud Services :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: pennywise, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.5) Gecko/2008120122 Spacechipmunk Firefox/3.0.5
Build Identifier: 

Possible wrong place to file that bug, but I didn't find a better place.

I'm currently using log4moz, and I found a bug

http://hg.mozilla.org/labs/weave/file/229b42ede71d/modules/log4moz.js

This is the version I'm using. On line 471 (Inside FileAppender.doAppend())

this._fos().write(message, message.length);

it should be

this._fos.write(message, message.length);

without the brackets after _fos.


Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Yeah that looks like a bug! I had not noticed it because I use the rotating file appender.

I've fixed it in the latest version in hg now.  Thanks a lot for the bug report!
Closing bug.  Thanks again.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Component: Weave → General
Product: Mozilla Labs → Weave
Target Milestone: -- → ---
QA Contact: weave → general
You need to log in before you can comment on or make changes to this bug.