mochitest-chrome: test_largemenu.xul sporadically fails

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
11 years ago
5 years ago

People

(Reporter: catlee, Assigned: enndeakin)

Tracking

({intermittent-failure})

Trunk
mozilla1.9.3a3
x86
macOS
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

If the dock on OSX is too large, then test_largemenu.xul will fail.  An example of the failure is:
*** 855 INFO Running chrome://mochikit/content/chrome/toolkit/content/tests/chrome/test_largemenu.xul...
*** 856 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/toolkit/content/tests/chrome/test_largemenu.xul | open normal top - got 91, expected 384
*** 857 INFO TEST-PASS | chrome://mochikit/content/chrome/toolkit/content/tests/chrome/test_largemenu.xul | open normal bottom
*** 858 INFO TEST-PASS | chrome://mochikit/content/chrome/toolkit/content/tests/chrome/test_largemenu.xul | open normal overflow
*** 859 INFO TEST-PASS | chrome://mochikit/content/chrome/toolkit/content/tests/chrome/test_largemenu.xul | menu scroll position
*** 860 INFO TEST-PASS | chrome://mochikit/content/chrome/toolkit/content/tests/chrome/test_largemenu.xul | open flipped position top
*** 861 INFO TEST-PASS | chrome://mochikit/content/chrome/toolkit/content/tests/chrome/test_largemenu.xul | open flipped position bottom
*** 862 INFO TEST-PASS | chrome://mochikit/content/chrome/toolkit/content/tests/chrome/test_largemenu.xul | open flipped position overflow
*** 863 INFO TEST-PASS | chrome://mochikit/content/chrome/toolkit/content/tests/chrome/test_largemenu.xul | menu scroll position
*** 864 INFO TEST-PASS | chrome://mochikit/content/chrome/toolkit/content/tests/chrome/test_largemenu.xul | open with scrolling top
*** 865 INFO TEST-PASS | chrome://mochikit/content/chrome/toolkit/content/tests/chrome/test_largemenu.xul | open with scrolling bottom
*** 866 INFO TEST-PASS | chrome://mochikit/content/chrome/toolkit/content/tests/chrome/test_largemenu.xul | open with scrolling overflow
*** 867 INFO TEST-PASS | chrome://mochikit/content/chrome/toolkit/content/tests/chrome/test_largemenu.xul | menu scroll position
*** 868 INFO TEST-PASS | chrome://mochikit/content/chrome/toolkit/content/tests/chrome/test_largemenu.xul | menu scroll position
*** 869 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/toolkit/content/tests/chrome/test_largemenu.xul | open small again top - got 91, expected 384
*** 870 INFO TEST-PASS | chrome://mochikit/content/chrome/toolkit/content/tests/chrome/test_largemenu.xul | open small again bottom
*** 871 INFO TEST-PASS | chrome://mochikit/content/chrome/toolkit/content/tests/chrome/test_largemenu.xul | open small again overflow
*** 872 INFO TEST-PASS | chrome://mochikit/content/chrome/toolkit/content/tests/chrome/test_largemenu.xul | menu scroll position

Setting the dock size to 49 seems to have fixed this problem on several of the unittest machines that were having problems, but it would nice if the test weren't so dependent on the dock size.

The magic invocation to change the dock size is:
defaults write com.apple.dock tilesize -int 49; killall Dock
Component: Chrome → XUL
Product: Testing → Core
QA Contact: chrome → xptoolkit.widgets
The test should probably be using 'screen.innerHeight' rather than 'screen.height' to get the screen area.
Joel - wasn't largemenu.xul one of the tests that had been failing on Fennec?  Since we weren't running Fennec on Mac OS X do we know what that spurious failure was from?  I'm wondering if this dock size issue is *all* that's wrong with this test.  Please correct if I'm mistaken...
This test just failed on the Linux unittest box 2 out of the last 3 cycles:

Linux mozilla-central unit test on 2009/01/22 03:25:40
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1232623540.1232628697.15512.gz
*** 870 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/toolkit/content/tests/chrome/test_largemenu.xul | context menu more space above top - got -778, expected -344

Linux mozilla-central unit test on 2009/01/22 04:11:46
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1232626306.1232632809.4619.gz
*** 868 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/toolkit/content/tests/chrome/test_largemenu.xul | context menu enough space below top - got -3, expected 7
34421 INFO Error: Unable to restore focus, expect failures and timeouts.
34430 INFO Error: Unable to restore focus, expect failures and timeouts.
34441 INFO Error: Unable to restore focus, expect failures and timeouts.
34446 INFO Error: Unable to restore focus, expect failures and timeouts.
34450 INFO Error: Unable to restore focus, expect failures and timeouts.
34457 INFO Error: Unable to restore focus, expect failures and timeouts.
6870 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/toolkit/content/tests/chrome/test_largemenu.xul | context menu enough space below top - got -3, expected 7

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1247269581.1247274586.7438.gz

reproduced on linux too.
Linux mozilla-central test everythingelse on 2009/07/15 01:18:36
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1247645916.1247647556.11819.gz
7036 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/toolkit/content/tests/chrome/test_largemenu.xul | context menu enough space below top - got -3, expected 7
Blocks: 438871
Whiteboard: [orange]
See also (Linux mozilla-central test everythingelse)
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1247752109.1247753663.27074.gz

Is this Linux issue really the same as the OS X bug described above, or should it be separate?
Neil, bz - you guys are the two people that have touched this test, which is still failing intermittently on Linux at least:

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1248445910.1248447798.12692.gz&fulltext=1
Linux mozilla-central test everythingelse on 2009/07/24 07:31:50

Can one of you gin up a fix or otherwise investigate the causes (particularly since it doesn't seem to be mac-specific)?
Should we try Neil's suggestion in comment 1?
I have no idea what this test is all about, sadly.  :(
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1248741838.1248743910.9816.gz
"context menu enough space below top - got -3, expected 7"
Linux mozilla-central test everythingelse on 2009/07/27 17:43:58
Platform --> All (and removing mention of OS X from summary), since this has been failing on Linux, too.

(If it's determined that the cross-platform issue is a different bug from the original OS X Dock issue, then we can open another bug; however, for now, it seems good to mark this one as cross-platform, since so many cross-platform failures have been noted here.)
OS: Mac OS X → All
Summary: test_largemenu.xul is dependent on OSX Dock size → test_largemenu.xul sporadically fails
Linux mozilla-central test everythingelse on 2009/07/28 10:02:29
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1248800549.1248802310.4371.gz
7042 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/toolkit/content/tests/chrome/test_largemenu.xul | context menu enough space below top - got -3, expected 7
No exactly the same as the more common "got -3, expected 7", but matches comment #3 - "context menu more space above top - got 7, expected -344"

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1249165283.1249166864.19017.gz
Linux mozilla-central test everythingelse on 2009/08/01 15:21:23
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1249762176.1249763681.11523.gz
Linux mozilla-central test everythingelse on 2009/08/08 13:09:36
... | context menu enough space below top - got -3, expected 7

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1249765931.1249774328.29578.gz
Linux mozilla-central unit test on 2009/08/08 14:12:11
... | context menu more space above top - got -778, expected -344
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1249942973.1249944510.25702.gz
Linux mozilla-central test everythingelse on 2009/08/10 15:22:53  
7102 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/toolkit/content/tests/chrome/test_largemenu.xul | context menu enough space below top - got -3, expected 7
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.5/1250085636.1250090234.32716.gz

Here's another slightly different failure on Firefox3.5

966 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/toolkit/content/tests/chrome/test_largemenu.xul | open normal top - got 442, expected 442.5
979 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/toolkit/content/tests/chrome/test_largemenu.xul | open small again top - got 442, expected 442.5
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.5/1250181904.1250186243.31500.gz
WINNT 5.2 mozilla-1.9.1 unit test on 2009/08/13 09:45:04
(same failure as comment 20)
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.5/1251293945.1251297888.10641.gz
WINNT 5.2 mozilla-1.9.1 unit test on 2009/08/26 06:39:05

... | open normal top - got 442, expected 442.5
... | open small again top - got 442, expected 442.5
Summary: test_largemenu.xul sporadically fails → mochitest-chrome: test_largemenu.xul sporadically fails
Version: unspecified → Trunk
The patch in bug 549672 fixes the issues with this test on Linux.
OS: All → Mac OS X
http://hg.mozilla.org/mozilla-central/rev/e0d293fe8408
Assignee: nobody → enndeakin
Status: NEW → RESOLVED
Closed: 10 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a3
This isn't fixed, no. This is supposed to be a Mac-specific bug.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6/1269285016.1269287489.27079.gz
Linux mozilla-1.9.2 test mochitest-other on 2010/03/22 12:10:16
Mass marking whiteboard:[orange] bugs WFM (to clean up TBPL bug suggestions) that:
* Haven't changed in > 6months
* Whose whiteboard contains none of the strings: {disabled,marked,random,fuzzy,todo,fails,failing,annotated,leave open,time-bomb}
* Passed a (quick) manual inspection of bug summary/whiteboard to ensure they weren't a false positive.

I've also gone through and searched for cases where the whiteboard wasn't labelled correctly after test disabling, by using attachment description & basic comment searches. However if the test for which this bug was about has in fact been disabled/annotated/..., please accept my apologies & reopen/mark the whiteboard appropriately so this doesn't get re-closed in the future (and please ping me via IRC or email so I can try to tweak the saved searches to avoid more edge cases).

Sorry for the spam! Filter on: #FFA500
Status: REOPENED → RESOLVED
Closed: 10 years ago7 years ago
Resolution: --- → WORKSFORME
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.