"is logged in as" (330) numeric displayed in wrong tab

RESOLVED FIXED

Status

--
minor
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: jilles+mozilla, Assigned: glenjamin+bmo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [cz-0.9.85])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.9.0.4) Gecko/2008111413 Firefox/3.0.4
Build Identifier: ChatZilla 0.9.84 [Firefox 3.0.4/2008111413]

The 330 numeric is used by various IRC servers (undernet-ircu, asuka, snircd, charybdis, ircd-seven) to show the services account a user is logged in as in WHOIS. Chatzilla understands this numeric and displays it like:
	===	jilles_ is logged in as jilles

However, if there is a query tab with the user, this appears in the active tab instead of in the query, like the other parts of the WHOIS output.

Apart from manual /whois commands (as described in Steps to Reproduce), this also goes wrong when a query tab is opened automatically because of an incoming message.

Reproducible: Always

Steps to Reproduce:
1. connect to a network running one of the mentioned ircds (e.g. quakenet, sorcerynet, freenode testnet) and find a user logged in with services
2. type /query theirnick to open a query tab
3. click on the server tab
4. type /whois theirnick
Actual Results:  
The "is logged in as" text appears in the server tab, while the rest of the whois output appears in the query tab.

Expected Results:  
All whois output appears in the query tab.
(Assignee)

Comment 1

10 years ago
Seems reasonable, I've reproduced this.

The reason is that for the rest of the whois responses there's a handler in CIRCServer defined in irc.js, but not for 330.
Because of this, e.user isnt defined on CIRCNetwork.on330.

I'll knock up a quick patch to create the User object in handlers.js - although perhaps it should be done in irc.js as well?
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: FreeBSD → All
Hardware: x86 → All
Version: unspecified → Trunk
(Assignee)

Comment 2

10 years ago
Created attachment 353830 [details] [diff] [review]
create a user object in network.on330
Assignee: rginda → glenjamin+bmo
Attachment #353830 - Flags: review?(gijskruitbosch+bugs)

Updated

10 years ago
Attachment #353830 - Flags: review?(gijskruitbosch+bugs) → review-
(Assignee)

Comment 3

10 years ago
Created attachment 354043 [details] [diff] [review]
merged 330 with the whois handler. e.user set in irc.js

much less hacky.
Attachment #353830 - Attachment is obsolete: true
Attachment #354043 - Flags: review?(silver)

Comment 4

10 years ago
Comment on attachment 354043 [details] [diff] [review]
merged 330 with the whois handler. e.user set in irc.js

>+        
>+        case 330:

Nit: trailing whitespace above this case.

r=silver with nit fixed.
Attachment #354043 - Flags: review?(silver) → review+

Comment 5

10 years ago
Checked in with nit fixed:
Checking in mozilla/extensions/irc/js/lib/irc.js;
/cvsroot/mozilla/extensions/irc/js/lib/irc.js,v  <--  irc.js
new revision: 1.128; previous revision: 1.127
done
Checking in mozilla/extensions/irc/xul/content/handlers.js;
/cvsroot/mozilla/extensions/irc/xul/content/handlers.js,v  <--  handlers.js
new revision: 1.188; previous revision: 1.187
done
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Whiteboard: [cz-0.9.85]
You need to log in before you can comment on or make changes to this bug.