Impossible to get new addon approved

VERIFIED DUPLICATE of bug 340287

Status

VERIFIED DUPLICATE of bug 340287
10 years ago
3 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5
Build Identifier: 

My extension still has not been approved/reviewed after 3 months. The queue becomes around 100 addons longer every two weeks. I can't even distribute it on my own website since the existence of AMO means that users don't trust anything not listed there. While the intention is that an addon not approved by AMO is "neutral", what happens is that users assume that all addons that are in the sandbox is a untrustworthy. Almost all of the new addons are ones written by a few people, such as "Brand Thunder".

Reproducible: Always

Steps to Reproduce:
1.Pour effort into writing browser extension
2.Submit to AMO
3.Get nowhere because it's still stuck in sandbox after 3 months.
Actual Results:  
Stuck in sandbox

Expected Results:  
On the main AMO site after a few weeks.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 340287
Verified dup
Status: RESOLVED → VERIFIED
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.