Thunderbird l10n linux nightly following wrong mozilla tree

VERIFIED FIXED

Status

P1
normal
VERIFIED FIXED
10 years ago
8 years ago

People

(Reporter: stef, Assigned: gozer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pl; rv:1.9.0.5) Gecko/2008122108 Firefox/3.0.5 Flock/2.0.3
Build Identifier: 

At least since 2008.12.18 linux comm-central l10n thunderbird nightly builds are following mozilla-central instead mozilla-1.9.1 which results in busted builds (missing file) for "green" locales, lack of testing packages for our qa teams and is generally wrong/bad.

Please fix that ASAP.

Reproducible: Always
(Reporter)

Updated

10 years ago
Blocks: 470669
Moving this to the right component, cc'ing our build engineer to take a look.

Axel - could this be an issue with not having resolved bug 468108?
Component: General → Server Operations
Product: Thunderbird → Mozilla Messaging
QA Contact: general → server-ops
Version: unspecified → other

Comment 2

10 years ago
No, this is a problem of the source steps which don't ensure to catch up with branch changes.

My guess is that client.py is stuck on a branch for the linux builder.

Comment 3

10 years ago
This doesn't block the infra bug 470669, IMHO.
No longer blocks: 470669
Status: UNCONFIRMED → NEW
Ever confirmed: true
ok, I see it: http://build.mozillamessaging.com/buildbot/production/builders/Linux%20comm-central%20l10n/builds/2296/steps/shell/logs/stdio (from http://build.mozillamessaging.com/buildbot/production/builders/Linux%20comm-central%20l10n/builds/2296)

comm-central is on the right branch, but for some reason, client.py has decided to pull mozilla-central rather than comm-central. Definitely needs gozer to fix this.
Assignee: nobody → gozer
Priority: -- → P1
(Assignee)

Comment 5

10 years ago
Created attachment 354173 [details] [diff] [review]
Tweak the regular expression used to detect mozilla-central

Turns out the regular expression used to detect wether mozilla/ is a clone of mozilla-central needed a little tweak. It expected the pull url to end with a '/',
which is actually optionnal.
Attachment #354173 - Flags: review?(bugzilla)
Attachment #354173 - Flags: review?(bugzilla) → review+
(Assignee)

Comment 6

10 years ago
comparing with http://hg.mozilla.org/comm-central
searching for changes
changeset:   1482:cf1802da787c
tag:         tip
user:        Philippe M. Chiasson <gozer@mozillamessaging.com>
date:        Mon Dec 22 11:33:05 2008 -0500
summary:     Bug 470671. Fix client.py's incorrect detection of mozilla-central clone when missing a trailing '/'. r=Standard8
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

10 years ago
v, thx!
Status: RESOLVED → VERIFIED

Comment 8

10 years ago
(In reply to comment #5)
> It expected the pull url to end with a '/', which is actually optional.
But preferred. Not noticed the "real url" warnings?
(Assignee)

Comment 9

10 years ago
If you meant this:

pulling from http://hg.mozilla.org//index.cgi/comm-central
real URL is http://hg.mozilla.org/comm-central

I'd say it's not much of a warning, and it doesn't even include a trailing '/'
You need to log in before you can comment on or make changes to this bug.