Last Comment Bug 470705 - 'word-spacing: normal' should be treated internally like '0'
: 'word-spacing: normal' should be treated internally like '0'
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: CSS Parsing and Computation (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla1.9.2a1
Assigned To: David Baron :dbaron: ⌚️UTC-10
:
: Jet Villegas (:jet)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-21 16:41 PST by David Baron :dbaron: ⌚️UTC-10
Modified: 2008-12-27 18:04 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (9.50 KB, patch)
2008-12-21 16:41 PST, David Baron :dbaron: ⌚️UTC-10
roc: review+
roc: superreview+
Details | Diff | Splinter Review

Description David Baron :dbaron: ⌚️UTC-10 2008-12-21 16:41:32 PST
Created attachment 354090 [details] [diff] [review]
patch

We were failing a few of the style system mochitests because the spec says that 'normal' should lead to a computed value of '0'.  This could be trivially fixed in the computed style code, but given that they should be treated the same way, I don't see any reason to propagate the difference between the two so far.

This changes things so we change mWordSpacing from nsStyleCoord to nscoord.  (The spec still says 'letter-spacing' should have a difference between 'normal' and '0'.)
Comment 1 David Baron :dbaron: ⌚️UTC-10 2008-12-27 18:04:45 PST
Fixed: http://hg.mozilla.org/mozilla-central/rev/a50ff010b3ff

Note You need to log in before you can comment on or make changes to this bug.