If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Add-ons show with latest version even if latest version does not support listed application (causes install button to fail)

RESOLVED WONTFIX

Status

addons.mozilla.org Graveyard
Public Pages
--
major
RESOLVED WONTFIX
9 years ago
2 years ago

People

(Reporter: Dave Garrett, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

9 years ago
Some add-ons show in the add-ons lists (i.e. popular, newest, etc.) for SeaMonkey that are not currently supported by any SeaMonkey version. No SeaMonkey metadata is included in the install.rdf and no install.js exists. The public page lists "Firefox" and the supported Firefox versions where the SeaMonkey versions should be. The "Add to Seamonkey" (or "Download Now" if not viewing with SeaMonkey) button links to the current version's XPI which will produce an error if you try to install it in SeaMonkey.

These add-ons aren't found in any searches, normal or advanced, with any version range.

Out of the top 20 SeaMonkey add-ons, the following three are affected by this:
https://addons.mozilla.org/en-US/seamonkey/addon/5721 - Fast Dial
https://addons.mozilla.org/en-US/seamonkey/addon/398 - Forecastfox
https://addons.mozilla.org/en-US/seamonkey/addons/versions/1419 - IE Tab

All of these extensions have an older version which has SeaMonkey support, yet the current version does not.

The listings and public pages should show with the last supported version. Most importantly, the download button shouldn't link to an incompatible XPI, especially when viewing from SeaMonkey.
(Reporter)

Comment 1

9 years ago
In these instances it might also be a good idea to show some kind of note indicating that the current version does not support the listed application yet an older version does.
(Reporter)

Updated

9 years ago
Summary: Add-ons show with latest version even if latest version does not support listed application → Add-ons show with latest version even if latest version does not support listed application (causes install button to fail)
The proper fix is for the add-on to support the application.  If the author won't do that a user can view older versions and install from there.  Offering older versions to users isn't something we want to do.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 3

8 years ago
Of course the proper fix is to support the application, but no one's going to. Supporting SeaMonkey 1.x is a bad idea; it's obsolete. No progress is going to be attempted on that front until version 2.0 actually ever comes out. The problem isn't so much that there are add-ons that have dropped support for it, but that AMO is listing all of them as supporting it.

If the stats I listed in comment 0 are still accurate, 3 out of the top 20 "SeaMonkey add-ons" have dropped support with SeaMonkey but are still listed as such. An alternative fix would be to just stop listing them in any SeaMonkey lists at all, which might make more sense. (file another bug?)
(Reporter)

Comment 4

8 years ago
Bah, you click the add-on in the list and it just redirects to the Firefox page now. So yeah, filed another bug to just have them not shown here as 498878.
That's interesting. That means, we should show add-ons if and only if their latest version is compatible with the current application.
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.