frameset that is displayed inside a frame of a frameset is not displayed in print preview

NEW
Unassigned

Status

()

10 years ago
9 years ago

People

(Reporter: declerckmpm, Unassigned)

Tracking

({regression, testcase})

1.9.0 Branch
regression, testcase
Points:
---
Bug Flags:
wanted1.9.0.x ?

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments, 3 obsolete attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; fr; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; fr; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5

With Firefox 3, Telhermes site (that I use as my diary...) is accessible but give a blank page with header and footer only.
It is working correctly with Firefox 2 and with I.E.
And I have not that problem with other sites that I use.

(seems close to 441207 problem except that it is only with one site!)

Reproducible: Always

Steps to Reproduce:
1.login to telhermes site
2.going to "votre agenda"
3.print
Actual Results:  
blank page with header/footer

Expected Results:  
print the diary of the day...
Component: General → Printing: Output
Product: Firefox → Core
QA Contact: general → printing

Comment 1

10 years ago
There doesn't seem to be a publically available account to test the site.

Could you please create a testcase that allows us to reproduce the problem?
See https://developer.mozilla.org/en/Reducing_testcases

This ensures that we work as much as possible on this problem. Thanks for reporting.
(Reporter)

Comment 2

10 years ago
Created attachment 354196 [details]
HTML of a simple page that I can't print
(Reporter)

Comment 3

10 years ago
Created attachment 354198 [details]
screen copy of the view before printing of the simple page

Comment 4

10 years ago
Thanks for your effort.

However, the tescase works fine for me. According to the screenshot*, you did not try to print the testcase but another page.

Please base your testcase on the site that is not working. Check the print preview while reducing the code, you may find the problem. If the code contains personal information replace them by simple words.

* If you take a screenshot, please simply paste it into MS Paint and save it as JPEG or PNG. That way it's more accessible.
(Reporter)

Comment 5

10 years ago
Created attachment 354279 [details]
View before printing as of today 23/12 test
(Reporter)

Comment 6

10 years ago
Created attachment 354280 [details]
Sceen to be printed as of 23/12
(Reporter)

Comment 7

10 years ago
Created attachment 354281 [details]
HTML of the page to be printed as of 23/12

Comment 8

10 years ago
(In reply to comment #7)
> Created an attachment (id=354281) [details]
> HTML of the page to be printed as of 23/12

Hm, thats the log in page again.

Please try to get the source of this page:
(In reply to comment #6)
> Created an attachment (id=354280) [details]
> Sceen to be printed as of 23/12

and reduce it according to https://developer.mozilla.org/en/Reducing_testcases

Please try to print / do a print preview of your testcase before attaching it to the bug, thanks.

Comment 9

10 years ago
Marc, can you please help us with a testcase?
We'll eventually have to close this bug, if there's no way for us to reproduce the problem you're seeing.
(Reporter)

Comment 10

10 years ago
What I propose is to give you the "Code Client=declerck" and the "Code Secret=decl" for a few days or up to you to finalize the testcase.

I feel not competent enough to help you without giving you access.

tell me if it helps.

If not, I will switch to IE which is working in that configuration and not bother you more.
Regards

Comment 11

10 years ago
Thank you for your trust.

I created a local copy of the problematic page which allows me to find the problem. You should change your Secret Code now to prevent that anybody can gain access.

Comment 12

10 years ago
Created attachment 356196 [details]
minimal testcase
Attachment #354196 - Attachment is obsolete: true
Attachment #354198 - Attachment is obsolete: true
Attachment #354280 - Attachment is obsolete: true

Comment 13

10 years ago
The bug here is, that a frameset that is displayed inside a frame of a frameset is not displayed in print preview.

This bug is a regression from Fx2, but occurs only on Fx3.0; 3.1 Beta 2 and current trunk work.

Oh, I made a small mistake in the testcase.. but it still exposes the bug.
Status: UNCONFIRMED → NEW
Component: Printing: Output → Print Preview
Ever confirmed: true
Flags: wanted1.9.0.x?
Keywords: regression, regressionwindow-wanted, testcase
OS: Windows Vista → All
Hardware: x86 → All
Version: unspecified → 1.9.0 Branch
Whiteboard: [fixed in 3.1; see comment 13]
display of bottom left frame in print prewiew of given testcase
works:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008040112 Minefield/3.0pre ID:2008040112
fails:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008040204 Minefield/3.0pre ID:2008040204

=> range:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2008-04-01+12%3A00&maxdate=2008-04-02+04%3A00&cvsroot=%2Fcvsroot

same with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4pre) Gecko/20090317 Shiretoko/3.1b4pre ID:20090317050332
and
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090317 Minefield/3.6a1pre ID:20090317101214
Keywords: regressionwindow-wanted
Summary: Printing "telhermes" website causes blankpage with header/footer only → frameset that is displayed inside a frame of a frameset is not displayed in print preview
Whiteboard: [fixed in 3.1; see comment 13]
(Reporter)

Comment 15

9 years ago
I use Mozilla 3.5.2 and the problem is still alive. Should I do something to help solving?
Regards
M Declerck
You need to log in before you can comment on or make changes to this bug.