Closed Bug 470744 Opened 11 years ago Closed 11 years ago

modal dialog "failed to connect to server" when network or server is offline blocks usability

Categories

(Thunderbird :: Mail Window Front End, defect)

x86
All
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 123440

People

(Reporter: zaffi, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5
Build Identifier: All

when browsing and reading mail, all modal alert interferes with using or reading!


human interface considerations:
when a modal dialog pops up, thunderbird's icon on the task bar flashes for a user intervention (it's a desireable Windows feature) as if something critical had happened, but since it's so frequent, i don't need to be bothered every X minutes or at all.

when having more than 1 account the problem is a real annoyance.
when having 8 accounts (like mine) it's a show-stopper.

(in windows it is possible to disable flashing task-bar icon, but it's global for all apps, and flashing taskbar icons are actually desirable behavior if it happens only once in a while)



BTW: 
other modal dialogs which block using the program:
 a. when sending a message fails
 b. when checking email fails
 c. master password dialog
 d. other errors



Reproducible: Always

Steps to Reproduce:
Mail servers can be inaccessible for various reasons:
 a. bad router/firewall
 b. blocked service (e.g. on some firewalled public-access hotspots)
 c. temporary network issues
 d. server maintenance
etc. 
it's very frequent particularly with mobile computers!

1. disconnect the network
2. get new messages

or

1. go with your laptop to a malfunctioning wifi hotspot
2. wait to next email sync

etc.

Actual Results:  
while reading or browsing or writing mail, a dialog interferes and distracts, forcing for clicking or pressing "enter"

Expected Results:  
possible solutions:
1. show the error note on a "self-closing side-box", (same as when receiving new mail)
2. show a "bad" indicator e.g. on status bar, (as in ms-outlook)
3. add a configuration parameter to disable modal-ness for ALL modal dialogs
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 123440
You need to log in before you can comment on or make changes to this bug.