Closed Bug 470861 Opened 12 years ago Closed 11 years ago

acid2 test does not display css image

Categories

(Firefox for Android Graveyard :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED
fennec1.0b2

People

(Reporter: jmaher, Assigned: Gavin)

References

Details

Attachments

(1 file)

The acid2 test displays an image by defining a lot of css attributes:
http://www.webstandards.org/files/acid2/test.html

If you click on "Take the acid2 test" nothing happens.  This works in firefox, and I don't see a simple reason why it wouldn't work in fennec.
This is probably a duplicate of bug 452286 (the test scrolls itself to display the image).
Depends on: 452286
Blocks: 473596
Duplicate of bug 464984 (which is a itself the duplicate of 452286), the proposed patch correct the problem.
This patch is extracted from the Mike's patch on bug 464984 which concern pretty much the same issue but have more requirements.

I think this bug should block bug 464984
http://www.mediacollege.com/internet/javascript/page/scroll.html

Seems to work not so bad. In fact we need to click on stop scroll at end of
page.
The scroll work each time we click on the text link but only the first time on
the button.
I'll investigate that.
What's wrong with this example refer to bug 479862.

The scrollTop value stay at the end of the page when we click on the button, so we can't more.
When we click on the text link the page move itself to the link after the mousedown and start begin to scroll from here.
No longer blocks: 464984
OK, I'm going to call this one fixed. I think bug 499212 and bug 479862 cover the problems with the page in comment 4, and I'll file a new bug for the strange rendering artifacts I see.
Assignee: nobody → gavin.sharp
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → B2
verified with 20090908 1.9.2 maemo nightly
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.