Checksetup.pl fails to check Oracle DB

RESOLVED INVALID

Status

()

Bugzilla
Installation & Upgrading
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: rojanu, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-GB; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4
Build Identifier: 

When running checksetup.pl on windows I get an error dialog
"This application has failed to start because OCI.dll was not found. Re-installing the application may fix this problem".  I haven't got Oracle and am using MySQL

Reproducible: Always

Steps to Reproduce:
1. Run Checksetup.pl
(Reporter)

Comment 1

9 years ago
Created attachment 354291 [details]
checksetup screenshot

Should have mentioned I am running on CVS tip

Comment 2

9 years ago
You may have installed DBD::Oracle, please uninstall it.

Comment 3

9 years ago
This problem has already been reported in bug 459982 comment 0 and bug 459982 comment 8.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 459982

Comment 4

9 years ago
To be more precise, the problem comes from ActivePerl which installs DBD::Oracle by default and you cannot uninstall it, even when not using Oracle (I have the same problem). For now, all you can do is to click OK when the error message is displayed.

Comment 5

9 years ago
OK, I managed to remove DBD-Oracle when you don't need it. The GUI doesn't let you do it, but you can easily remove it from the command line:

ppm remove --area perl DBD-Oracle

Then checksetup.pl no longer complains.
Resolution: DUPLICATE → INVALID
You need to log in before you can comment on or make changes to this bug.