Closed Bug 470915 Opened 13 years ago Closed 13 years ago

Transition "Bookmark All Tabs" to same UI as "Bookmark This Page"

Categories

(Firefox :: Bookmarks & History, defect)

x86_64
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 459958

People

(Reporter: kngspook, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.5) Gecko/2008120121 Firefox/3.0.5
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.5) Gecko/2008120121 Firefox/3.0.5

First, having two different UIs for very similar functions is confusing and bad form to users.
Secondly, using the old interface with "Bookmark All Tabs..." means new Bookmarking functions can't be used which logically should be available; eg.:
2A. does not list Unsorted Bookmarks as a possible destination.
2B. does not allow bookmarks to be collectively added at addition time.


Reproducible: Always

Steps to Reproduce:
1. Open a tab.
2. Bookmarks->Bookmark This Page
3. Note the interface
4. Open another tab.
5. Bookmarks->Bookmark All Tabs...
6. Note the interface is different from the one in Step 3.
Actual Results:  
Old interface appeared.

Expected Results:  
New interface appears, similar in style to "Bookmark This Page".
most has been fixed with bug 411261, but notice the new dialog is only used when the context is "bookmark this page", other contexts use classic window dialog.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 411261
take a look at bug 459958 also, if you have any suggestion that would be a good place to go.
My bug _was_ that the new dialog is only in the "Bookmark This Page" context; it would make sense that both contexts use it...

I think bug 459958 is more promising though...maybe switch the dup to that one, if it matters?
(In reply to comment #3)
> it would make sense that both contexts use it...

it probably would not since the context would not be clear then.
changing dupe.
Duplicate of bug: 459958
Well, it should be clear enough if you change the header from "Page Bookmarked" to "All Tabs Bookmarked".  I didn't mean that they had to be bit/pixel-level the same, just functionally (primarily) and look-and-feel-ly (secondarily) the same.
You need to log in before you can comment on or make changes to this bug.