"Unsorted Bookmarks" should appear in Bookmarks menu.

RESOLVED FIXED in Firefox 4.0b7

Status

()

P5
enhancement
RESOLVED FIXED
10 years ago
8 years ago

People

(Reporter: kngspook, Unassigned)

Tracking

unspecified
Firefox 4.0b7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.5) Gecko/2008120121 Firefox/3.0.5
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.5) Gecko/2008120121 Firefox/3.0.5

"Unsorted Bookmarks" should appear in Bookmarks menu, or at least there should be an option to.  Its annoying to have to open Organize Bookmarks every time you want to access something you just stashed there quickly...


Reproducible: Always

Steps to Reproduce:
1. Open Bookmarks->Unsorted Bookmarks->[bookmark of choice]

Actual Results:  
Its not there.

Expected Results:  
It should be available somewhere.
i doubt about this, since unsorted bookmarks could contain many items... hwv this should be doable in future by simply dragging the query from the library to the menu, bug 435851 should be the starting point.
Keywords: uiwanted
What would be "Unsorted" about it? Personally, all immediate bookmarks i put in the menu (can't put *too* many as it clutters the whole ui), and stuff i don't need, but keep "archived" i put in the Unsorted Bookmarks folder...
(Reporter)

Comment 3

10 years ago
(In reply to comment #1)
> i doubt about this, since unsorted bookmarks could contain many items... hwv
> this should be doable in future by simply dragging the query from the library
> to the menu, bug 435851 should be the starting point.
Doing this just makes a copy...I'm looking for something akin to a symlink.
i've said *IN FUTURE*, indeed
true, this could be a shortcut as we have with the Toolbar folder in the menu.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Mac OS X → All
Priority: -- → P5
Hardware: x86_64 → All
We said no to this in the original design because this would quickly grow too large based on projected usage, especially if we added a quick tagging UI.  Why are we revisiting this?
(Reporter)

Comment 7

10 years ago
Would there be a a performance impact?  If so, would it be only when trying to view Unsorted Bookmarks in the menu?

Updated

9 years ago
Duplicate of this bug: 490516

Comment 9

9 years ago
I also would like to have an "unsorted bookmark folder" in FF by standard.
Drives me crazy having to open "organize booksmarks" in order to view my unsorted booksmarks.

For the time being I installed the Addon "Unsorted Bookmarks Folder Menu"
https://addons.mozilla.org/de/firefox/addon/7269

Please make this a standard feature/behavior in FF.
actually the new appmenu button and the new bookmarks button on the toolbar have unsorted toolbar entry that brings to the library. That form is the currently agreed solution for now, and we won't make a submenu, that on the other side can be easily done by a extension, and probably also by creating a saved search in the Library.

So, this is fixed from the point of view of adding a quick shortcut to unsorted, adding a submenu so far is wontfix, it's possible in future something will change, but there is no point in leaving this open since it was discussed enough.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Keywords: uiwanted
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b7
You need to log in before you can comment on or make changes to this bug.