Closed Bug 470948 Opened 13 years ago Closed 13 years ago

Update Mozilla.org staff page

Categories

(www.mozilla.org :: General, defect)

x86
All
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 233840

People

(Reporter: gen, Unassigned)

References

()

Details

Mozilla.org "staff" does not exist in the form on the website anymore.  Can we have this page either deleted or updated to reflect the actual situation with Mozilla.org staff?
I'm fine with archiving this page.  There's an existing discussion about this over in bug 233840 so I'm marking this as a duplicate.  Please add any comments as needed there.  We did just changes the roles.html page to remove the link to staff, but haven't archived it yet.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 233840
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.