Drag feedback should support trees where things can only go into folders, not into the tree

RESOLVED FIXED

Status

()

Core
XUL
P3
normal
RESOLVED FIXED
18 years ago
18 years ago

People

(Reporter: laurel, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+])

(Reporter)

Description

18 years ago
See bugzilla bug #36583 

To capsulize, drag&drop to a folder within an expanded folder hierarchy can
sometimes underline both the root folder and target subfolder.  This is
confusing to user -- does not immediately convey the intended destination target
has been selected.

Steps to reproduce:
1.  Login to mail account and setup a folder hierarchy similar to this, where a
folder has subfolders, but there is at least one subfolder immediately below the
root which has no subfolder of its own, then the last subfolder of the root does
have its own subfolders... something like this:

    Folder A
    |
    --- Foobar One (this has no subfolders)
    |
    --- Foobar Two (this has no subfolders)
    |
    --- Foobar Three  (this has subfolder(s))
        |
        ---  Sub1 of foobar three

2.  Expand folder A, or the root of this mini hierarchy but leave Foobar Three's
hierarchy collapsed.

    Folder A    EXPANDED
    |
    --- Foobar One (this has no subfolders)
    |
    --- Foobar Two (this has no subfolders)
    |
    --- Foobar Three  COLLAPSED

3.  Select a message in the account's inbox and drag it to Folder A in the
example.

Actual result:  What you'll see is the highlight/grey line appear at Folder A
and the bold underline of selection target appear under Folder Three.  The
selection of the one single folder for destination is somewhat diffused and
selection appears to encompass the subhierarchy.  Moving the mouse around a bit
will often move the bold line to the proper folder (Folder A).

Expected result:  One single and very clear, clean selection of the target
folder.


The original bug #36583 was marked invalid by pinkerton and his comments were:
"this is the intended behavior. the line under folder three is to show that it 
will go in folder A at the end of its child list if dropped on folder A.
However, this particular tree doesn't have the concept of inserting something
into the tree between the items.

Marking this INVALID. If you want a bug that drag feedback in general needs to 
support trees where things can only go into folders, not into the tree, file a 
new one."
(Reporter)

Updated

18 years ago
Summary: Drag feedback should support trees where things can only go into folders, not into the tree → Drag feedback shouldsupport trees where things can only go into folders, not into the tree
(Assignee)

Comment 1

18 years ago
A better description for this bug is:

the only drop feedback for a tree that can only put things into folders should be 
folder highliting. The lines indicating an item will be inserted between two 
folders is meaningless and confusing.

nominating for beta3, we'll see what happens.
Keywords: nsbeta3
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Summary: Drag feedback shouldsupport trees where things can only go into folders, not into the tree → Drag feedback should support trees where things can only go into folders, not into the tree
(Assignee)

Comment 2

18 years ago
fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Updated

18 years ago
Whiteboard: [nsbeta3+]

Comment 3

18 years ago
I still see the highlight/grey line appear at Folder A and the bold underline of
selection target appear under Folder Three with WinNT (20001102) and Linux
(20001101)
You need to log in before you can comment on or make changes to this bug.