Closed Bug 471096 Opened 11 years ago Closed 11 years ago

My bookmarks show as (no title), after upgrading to Firefox 3.0.5

Categories

(Firefox :: Bookmarks & History, defect, critical)

3.0 Branch
All
macOS
defect
Not set
critical

Tracking

()

RESOLVED INCOMPLETE

People

(Reporter: alrbailey, Unassigned)

Details

(Keywords: dataloss)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.0.5) Gecko/2008120121 Firefox/3.0.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.0.5) Gecko/2008120121 Firefox/3.0.5

All bookmarks are missing and only showing up as 3 (no title) lines. I have tried to restore the bookmarks with foxmarks and nothing happened.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Actual Results:  
Tried to import my bookmarks from file and nothing happened.

Expected Results:  
Bookmarks restored.
Attached image Screen shot of error
Please give Firefox safe mode a try:
http://support.mozilla.com/en-US/kb/Safe+Mode
Keywords: dataloss
Summary: My bookmarks show as (no title), after upgrading to Firefox 3.5. → My bookmarks show as (no title), after upgrading to Firefox 3.0.5
Version: unspecified → 3.0 Branch
from which version do you have upgraded? 3.0.4 or previous?
It was an automatic update from the previous version. I am not sure what that was, since it does automatic updates in 3.0.
could you guess if previous version was a 3.0.x, a 3.0 beta, or a 2.x one?

First of all make a backup of your profile folder , be sure you have a backup.
http://support.mozilla.com/kb/Backing+up+your+information

Check places.sqlite file in you profile folder, if it is not too big, you can send it by mail to me for analysis.

then go to your profile folder and try to delete places.sqlite file, start Firefox and see if your old bookmarks are restored, if that does not work still try in Bookmarks / Organize Bookmarks, go to Import and Backup and choose Restore, choose a backup date BEFORE the upgrade.

You can also take a look at: http://support.mozilla.com/kb/Lost+Bookmarks

Let me know your results.
I've seen the identical behavior lately with one of my testing profiles. The bookmarks are all present but the bookmarks root folders (bookmarks menu and unfiled bookmarks) are shown as "no title".

Reporter, have you deleted your bookmarks before you have made the screenshot due to a re-import with foxmarks?
Component: Bookmarks & History → Places
QA Contact: bookmarks → places
Hardware: PowerPC → All
not enough informations to reproduce this
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → INCOMPLETE
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.