Need to not allow assignment to 3rd pty users

VERIFIED INVALID

Status

()

Bugzilla
Creating/Changing Bugs
--
minor
VERIFIED INVALID
9 years ago
9 years ago

People

(Reporter: Ted Kim, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 2.0.50727; InfoPath.2; .NET CLR 3.0.04506.30)
Build Identifier: Bugzilla 3.0.6

I am enthusiatic bugzilla user and also got a responsibility on bugzilla system.
one of my client requested how to block assignment of 3rd party's access.
Main System engineers are using specific product[DBMS project] in bugzilla, and 3rd party engineering team is supporting the project.

and the 3rd party team is mainly entering new issue into bugzilla.
but, my client wants to not allow the authority of 3rd party to assign to main system engineer.
it means 3rd party engineers can only enter new issue in bugzilla, and assignment will be processed by following default assignee.

Current Bugzilla system allows all members can assign to any members.

My client wants to use the assignment in main system engineer's hand.



Reproducible: Always

Steps to Reproduce:
1.create new accounts for A-Guy and B-Guy, C-Guy
2.create new product " DBMS"
3.I am admin and give full previleges to A and B guys, not C-Guy
4.Only C-Guy can enter new issue in the produce, DBMS
5.but admin cannot find any option to block assignment authority of C-Guy.
6.as a result, C-guy can assign new issue anyone when enter new issue.

Actual Results:  
as a result, C-guy can assign new issue anyone when enter new issue.


Expected Results:  
C-guy should only enter new issue and change some options like component and others except assignment.
How admin can control c-guy's assignment previliege?

A and B guys can control all functions and management on the product
C guy should not control or change assignment, so default assignment should be displayed in entering view of bugzilla
It's a support question, not a bug.
Check editbugs group on your system.

Comment 2

9 years ago
use the newsgroups if you need support

removing editbugs would be a good start. if necessary you can create a custom template for these users.

but have you considered training these people not to touch knobs they shouldn't be touching? sometimes education is a good thing.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID

Comment 3

9 years ago
You don't need to customize templates. Use the strict_isolation and usevisibilitygroups parameters, and set group settings correctly for your products, especially the CANEDIT bit. Definitely a support question.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

9 years ago
Thanks to all,

I could find how to control it.
As I used the strict_isolation and usevisibilitygroups parameters properly,
Each User could get different authority to change options.

thanks again.
You need to log in before you can comment on or make changes to this bug.