QA Notice: Package has poor programming practices

RESOLVED DUPLICATE of bug 439144

Status

NSPR
NSPR
RESOLVED DUPLICATE of bug 439144
10 years ago
9 years ago

People

(Reporter: Toralf Förster, Assigned: Wan-Teh Chang)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.19) Gecko/20081221 Firefox/2.0.0.19
Build Identifier: dev-libs/nspr-4.7.3

From the Gentoo's log :

 * Please do not file a Gentoo bug and instead report the above QA
 * issues directly to the upstream developers of this software.
 * Homepage: http://www.mozilla.org/projects/nspr/


Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Actual Results:  
* QA Notice: Package has poor programming practices which may compile
 *            fine but exhibit random runtime failures.
 * ../../../../mozilla/nsprpub/pr/src/io/prfdcach.c:165: warning: dereferencing type-punned pointer will break strict-aliasing rules
../../../../mozilla/nsprpub/pr/src/io/prfdcach.c:224: warning: dereferencing type-punned pointer will break strict-aliasing rules
../../../../mozilla/nsprpub/pr/src/misc/prthinfo.c:109: warning: dereferencing type-punned pointer will break strict-aliasing rules
../../../../mozilla/nsprpub/pr/src/misc/prthinfo.c:235: warning: dereferencing type-punned pointer will break strict-aliasing rules
../../../../mozilla/nsprpub/pr/src/pthreads/ptio.c:903: warning: dereferencing type-punned pointer will break strict-aliasing rules


Expected Results:  
now warning

stable Gentoo system
gcc version 4.1.2 (Gentoo 4.1.2 p1.0.2)
(Assignee)

Comment 1

9 years ago
Thanks for the bug report.  I'm sorry that I forgot to mark
this bug as a duplicate.  I have a patch that fixes these
warnings in bug 439144.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Target Milestone: --- → 4.8
Duplicate of bug: 439144
You need to log in before you can comment on or make changes to this bug.