QA Notice: Package has poor programming practices

RESOLVED DUPLICATE of bug 467092

Status

NSS
Build
RESOLVED DUPLICATE of bug 467092
10 years ago
9 years ago

People

(Reporter: Toralf Förster, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.19) Gecko/20081221 Firefox/2.0.0.19
Build Identifier: dev-libs/nss-3.12.2_rc1

 * QA Notice: Package has poor programming practices which may compile
 *            fine but exhibit random runtime failures.



Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Actual Results:  
 * pkistore.c:318: warning: dereferencing type-punned pointer will break strict-aliasing rules
pkistore.c:454: warning: dereferencing type-punned pointer will break strict-aliasing rules
pkistore.c:502: warning: dereferencing type-punned pointer will break strict-aliasing rules
pkix_certselector.c:103: warning: dereferencing type-punned pointer will break strict-aliasing rules
pkix_certselector.c:317: warning: dereferencing type-punned pointer will break strict-aliasing rules
pkix_certselector.c:618: warning: dereferencing type-punned pointer will break strict-aliasing rules
pkix_certselector.c:739: warning: dereferencing type-punned pointer will break strict-aliasing rules
pkix_certselector.c:1569: warning: dereferencing type-punned pointer will break strict-aliasing rules
pkix_certselector.c:1745: warning: dereferencing type-punned pointer will break strict-aliasing rules
...
cmssigdata.c:1037: warning: dereferencing type-punned pointer will break strict-aliasing rules
cmssigdata.c:1039: warning: dereferencing type-punned pointer will break strict-aliasing rules
blapitest.c:3464: warning: dereferencing type-punned pointer will break strict-aliasing rules
install.c:443: warning: dereferencing type-punned pointer will break strict-aliasing rules

Expected Results:  
no warnings

tfoerste@n22 ~ $ gcc -v
Using built-in specs.
Target: i686-pc-linux-gnu
Configured with: /var/tmp/portage/sys-devel/gcc-4.1.2/work/gcc-4.1.2/configure --prefix=/usr --bindir=/usr/i686-pc-linux-gnu/gcc-bin/4.1.2 --includedir=/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/include --datadir=/usr/share/gcc-data/i686-pc-linux-gnu/4.1.2 --mandir=/usr/share/gcc-data/i686-pc-linux-gnu/4.1.2/man --infodir=/usr/share/gcc-data/i686-pc-linux-gnu/4.1.2/info --with-gxx-include-dir=/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/include/g++-v4 --host=i686-pc-linux-gnu --build=i686-pc-linux-gnu --disable-altivec --enable-nls --without-included-gettext --with-system-zlib --disable-checking --disable-werror --enable-secureplt --disable-libunwind-exceptions --disable-multilib --enable-libmudflap --disable-libssp --disable-libgcj --with-arch=i686 --enable-languages=c,c++,treelang,fortran --enable-shared --enable-threads=posix --enable-__cxa_atexit --enable-clocale=gnu
Thread model: posix
gcc version 4.1.2 (Gentoo 4.1.2 p1.0.2)

Comment 1

9 years ago
Thanks for the bug report.  This is a know issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 467092
You need to log in before you can comment on or make changes to this bug.