If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

background appears and then disappears

VERIFIED WORKSFORME

Status

()

Core
Layout: Tables
P3
normal
VERIFIED WORKSFORME
18 years ago
17 years ago

People

(Reporter: jesup, Assigned: karnaze (gone))

Tracking

Trunk
Future
x86
FreeBSD
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
The colored background of the left RowSpan cell appears, and then as the page
finishes loading, it disappears.  Interestingly, if you remove the "colspan=2"
from the final row (or remove the row), only a 1x1 pixel area switches from
colored background to default background (white).

The example is cut down from infospace.com
(Reporter)

Comment 1

18 years ago
Created attachment 12195 [details]
Test case

Comment 2

18 years ago
this worksforme on win32 M18 073108 build.  are you still seeing this with
current builds?
(Reporter)

Comment 3

18 years ago
Still happens for me with fresh pull 8/1/00.

I just noted something: when it happens, at the bottom of the screen it says
"Sending request to a1040.g.akamai.net".  When it works (with the minimal
example), it says "Document: Done (1.776 secs)".  In both cases, the stdout says
that the page loaded successfully, and the image in the corner is stable.

It happens more frequently with the original URL
(http://inspcl.infospace.com/info/classads/iclass?cat=gene&op=search&PDBN=INSPGPRICE&NEXTF=switchv&QFDMA=0&QDMA=&QCQS=&QC=&QS=&QZ=&QO=&QREG=0&QVCAT=1&_debug=&_DEFDMA=&QVSCAT=1&QVCAT=1&QVSSCAT=1&firstsearch=1&CATFILE=/classads/gene_mstr.html&VTITLE=General+Ads&TITLE=&_ADV_ST=2&_ADV_SRC=&_ADV_USR=);
with my little test case, it appears to happen only the first time after I start
up - reload doesn't cause it (or doesn't cause it anymore).

Comment 4

17 years ago
over to HTML Tables
Assignee: asa → karnaze
Status: UNCONFIRMED → NEW
Component: Browser-General → HTMLTables
Ever confirmed: true
QA Contact: doronr → chrisd

Comment 5

17 years ago
I can reproduce this every time with a debug build on WinNT with code from 8/19.
Load the attached test case (7/31/00 16:21).  It displays correctly.  Then hit 
reload.  The bottom half of the first cell (the rowspan'd cell) doesn't paint 
it's background.  The top half does paint.
If you replace the image URL with a non-existent image reference, it paints 
fine.  Makes me think it has something to do with the incremental reflow 
generated when the image loads, maybe.

Marking Future, we have bigger fish to fry.
Target Milestone: --- → Future

Comment 6

17 years ago
WORKSFORME
Platform: PC
OS: Windows 98
Mozilla Build: 2001012205

marking as such.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

17 years ago
Problem indeed seems to be gone
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.