multiline imput field no way back

RESOLVED FIXED

Status

Other Applications
ChatZilla
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: tonda kavalec, Assigned: James Ross)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [cz-0.9.85])

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b3pre) Gecko/20081226 SeaMonkey/2.0a3pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b3pre) Gecko/20081226 SeaMonkey/2.0a3pre

changing single input field in chatzilla to multi-line-field, it is not possible to switch back

Reproducible: Always

Steps to Reproduce:
1. switch to multi-line-input-fiel in chatzilla (mouse / keyboard)
2. try to switch back (mouse / keyboard)
3.
Actual Results:  
switching back to single-input-field is not possible

Expected Results:  
it is always possible to switch back to single-input-field

Updated

9 years ago
Assignee: nobody → rginda
Component: UI Design → ChatZilla
Product: SeaMonkey → Other Applications
QA Contact: ui-design → chatzilla

Comment 1

9 years ago
Looks to be broken in Windows too.

ChatZilla 0.9.84 [SeaMonkey 2.0a3pre/20081229001333]

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20081229 SeaMonkey/2.0a3pre

Comment 2

9 years ago
Regression range:

ChatZilla 0.9.84 [SeaMonkey 2.0a3pre/20081221001336] - works

ChatZilla 0.9.84 [SeaMonkey 2.0a3pre/20081222001336] - broken
(Assignee)

Comment 4

9 years ago
I'm pretty sure this is a regression from bug 436759.
Blocks: 436759
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
OS: Linux → All
Hardware: x86 → All
Version: unspecified → Trunk
(Assignee)

Comment 5

9 years ago
To be clear, the problem here is that the PrefManager is calling onPrefChanged in prefs.js for the "multiline" pref with the old value as "false" even when it should be "true". The code thus wont switch to single-line as it sees false -> false and aborts.
(Assignee)

Comment 6

9 years ago
OK, what I think is happening is that the PrefManager is removing the old value in clearPref BEFORE we actually remove the preference. For the normal setPref code-path, the internal value is only updated after setting the pref.

I should be able to patch this...
(Assignee)

Comment 7

9 years ago
Created attachment 354784 [details] [diff] [review]
Always update the realValue after changing the preference

This fixes the problem with the multiline input box; I commented on both places so nobody regresses this in the future.
Assignee: rginda → silver
Status: NEW → ASSIGNED
Attachment #354784 - Flags: review?(gijskruitbosch+bugs)

Comment 8

9 years ago
Comment on attachment 354784 [details] [diff] [review]
Always update the realValue after changing the preference

Nice one!
r=me
Attachment #354784 - Flags: review?(gijskruitbosch+bugs) → review+

Updated

9 years ago
Duplicate of this bug: 472523
- Workaround: The multiline input box can be resized, even to single line, by dragging its top side.
- Problem with this workaround: Ctrl+Up still isn't active, until you /quit then reopen ChatZilla.

This is probably a bit late for a workaround, since it looks like this bug will soon be FIXED.

Comment 11

9 years ago
(In reply to comment #10)
> - Workaround: The multiline input box can be resized, even to single line, by
> dragging its top side.
> - Problem with this workaround: Ctrl+Up still isn't active, until you /quit
> then reopen ChatZilla.

And enter doesn't send messages, tab doesn't autocomplete, and there is no history. So it's a really lousy workaround... this just needs to get checked in, and it will...

> 
> This is probably a bit late for a workaround, since it looks like this bug will
> soon be FIXED.
(Reporter)

Comment 12

9 years ago
for me Enter sends messages
tab does autocomplete
ctrl + up works as well
(Assignee)

Comment 13

9 years ago
Checked in --> FIXED.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Whiteboard: [cz-0.9.85]
You need to log in before you can comment on or make changes to this bug.