Closed Bug 471235 Opened 11 years ago Closed 11 years ago

IsAttributeMapped appears in many SVG class definitions with NS_IMETHODIMP_ instead of NS_IMETHOD_

Categories

(Core :: SVG, defect, trivial)

defect
Not set
trivial

Tracking

()

RESOLVED FIXED
mozilla1.9.2a1

People

(Reporter: craig.topper, Assigned: craig.topper)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20081226 Shiretoko/3.1b3pre Firefox/3.1b3pre
Build Identifier: 

Many classes in SVG content have IsAttributedMapped incorrectly declared in the class definitions with NS_IMETHODIMP_ instead of NS_IMETHOD_. This results in a missing "virtual" keyword when the macro is expanded. Since all these classes inherit from other classes with a proper declaration this doesn't cause a real problem.

Reproducible: Always
Attachment #354535 - Flags: review?(longsonr) → review+
Attachment #354535 - Flags: superreview?(roc)
Attachment #354535 - Flags: superreview?(roc) → superreview+
Assignee: nobody → craig.topper
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: checkin-needed
Whiteboard: [needs landing]
Comment on attachment 354535 [details] [diff] [review]
Patch that cleans up the files with the problem
[Checkin: Comment 2]

http://hg.mozilla.org/mozilla-central/rev/bc174f0cc10d
Attachment #354535 - Attachment description: Patch that cleans up the files with the problem → Patch that cleans up the files with the problem [Checkin: Comment 2]
Status: NEW → RESOLVED
Closed: 11 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: [needs landing]
Target Milestone: --- → mozilla1.9.2a1
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.