Cookie confirmation dialog centered in primary display instead of the browser window.

RESOLVED DUPLICATE of bug 470356

Status

()

RESOLVED DUPLICATE of bug 470356
10 years ago
10 years ago

People

(Reporter: roy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.5) Gecko/2008121622 Ubuntu/8.04 (hardy) Firefox/3.0.5
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.5) Gecko/2008121622 Ubuntu/8.04 (hardy) Firefox/3.0.5

With the last update, cookie confirmation dialogs appear centered in the primary display instead of being centered in the browser window responsible for the dialog.  I also noted this on a Windows machine with dual monitors.  In the Windows case, the confirmation dialog appears centered in the primary monitor, even though the browser window is positioned on the secondary monitor.

Reproducible: Always

Steps to Reproduce:
1. Enable 'ask me every time' for cookies.
2. Go to a site that will set a cookie.
3. Observe the confirmation dialog centered in the primary display, regardless of the position of the browser window.
Actual Results:  
The cookie confirmation dialog was centered in the primary display, rather than centered in the browser window.

Expected Results:  
The cookie confirmation dialog should be centered in the browser window.

I only use the default theme.
Whiteboard: [DUPEME]
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Whiteboard: [DUPEME]
Duplicate of bug: 470356
You need to log in before you can comment on or make changes to this bug.