If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"bookmark this page" resets the clipboard every time you enter the window

VERIFIED FIXED in Firefox 3.6a1

Status

()

Firefox
Bookmarks & History
VERIFIED FIXED
9 years ago
8 years ago

People

(Reporter: Sanjeev Sharma, Assigned: dao)

Tracking

(4 keywords)

3.0 Branch
Firefox 3.6a1
x86
Linux
access, polish, ue, verified1.9.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [polish-easy] [polish-interactive][polish-p4])

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.5) Gecko/2008121622 Ubuntu/8.04 (hardy) Firefox/3.0.5
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.5) Gecko/2008121622 Ubuntu/8.04 (hardy) Firefox/3.0.5

when you enter the "bookmark this page" window, all clipboard data is lost, and replaced with just the titlebar text of the page that is being bookmarked.

This When this window loses focus it goes away, so that every time you enter the window this happens. 

So there's no way to copy and paste data into any of the fields - tags, description, name, anything. 

If you copy data from an emacs instance, then go to firefox and press "Ctrl-D", the data that was copied to the clipboard is gone.  Now go back to emacs to re-copy the same data and the "bookmark this page" dialog goes away, preventing you from copying and pasting (because you will have to bring up that window anew, and lose the clipboard data again) 

It's also pretty bad in that one may be working in another application, have some data in the clipboard, come to firefox and bookmark a page, while doing no explicit user-level action to the clipboard, return to the original application, and the clipboard data is gone. 

As I understand it, the clipboard is only supposed to be modified if the user explicitly requests that it be modified.  



Reproducible: Always

Steps to Reproduce:
1. copy data to the clipboard
2. bring up the "add a bookmark" dialog (press Ctrl-D) - you don't even need to actually bookmark anything
3. close that box
4. paste data 
5. the original data is gone, replaced by the title  of the page to be bookmarked. 

Actual Results:  
clipboard data modified even though user never requested copied to clipboard, or made an explicit X selection 

Expected Results:  
unless there is an explicit user X selection or a "copy" menu selection, the clipboard data should be untouched 

not changed the clipboard data
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.6pre) Gecko/2008121605 GranParadiso/3.0.6pre

This works fine for me on Windows.
(Assignee)

Updated

9 years ago
Assignee: nobody → dao
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Keywords: access, polish, ue
Whiteboard: [polish-easy] [polish-interactive]
(Assignee)

Updated

9 years ago
Version: unspecified → 3.0 Branch
(Assignee)

Updated

9 years ago
Blocks: 412027
(Assignee)

Comment 2

9 years ago
Created attachment 354601 [details] [diff] [review]
patch
Attachment #354601 - Flags: review?(mano)
Attachment #354601 - Flags: review?(mano) → review+
(Assignee)

Comment 3

9 years ago
http://hg.mozilla.org/mozilla-central/rev/a545234a6d16
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.2a1
(Assignee)

Updated

9 years ago
Attachment #354601 - Flags: approval1.9.1?
Comment on attachment 354601 [details] [diff] [review]
patch

a191=beltzner
Attachment #354601 - Flags: approval1.9.1? → approval1.9.1+
(Assignee)

Comment 5

9 years ago
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/03186fc10229
Keywords: fixed1.9.1
verified FIXED on Shiretoko: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3 ID:20090305133223

and on trunk build: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090331 Minefield/3.6a1pre ID:20090331030637
Status: RESOLVED → VERIFIED
Keywords: fixed1.9.1 → verified1.9.1
This bug's priority relative to the set of other polish bugs is:
P4 - Polish issue that is rarely encountered, and is easily identifiable.

Only encountered by users who leverage the X selection, otherwise easily identifiable as a problem.
Whiteboard: [polish-easy] [polish-interactive] → [polish-easy] [polish-interactive][polish-p4]
You need to log in before you can comment on or make changes to this bug.