Shredder doesn't show the chinese sender name while reading newsgroup

RESOLVED DUPLICATE of bug 468351

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 468351
9 years ago
9 years ago

People

(Reporter: wilsonymc, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US) AppleWebKit/525.19 (KHTML, like Gecko) Chrome/1.0.154.42 Safari/525.19
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b3pre) Gecko/20081229 Shredder/3.0b2pre

When shredder is used to read the newsgroup, if the sender's name is just simply Chinese characters (Big5), i.e. without Q-Encoding, the shredder seems cannot resolve the characters and therefore use empty string to as the sender name to fill the "From" column.

Reproducible: Always

Steps to Reproduce:
1. Subscribe a newsgroup
2. Read a post that has a "Big5" encoding name without Q-Encoding
Actual Results:  
The sender name is missing.

Expected Results:  
The correct Chinese character can be shown in the "From" column

Comment 1

9 years ago
Sounds like a dupe of bug 468351.
Reporter, can you attach such a message, either as .eml or mbox?
(Reporter)

Comment 2

9 years ago
Created attachment 354823 [details]
eml message with Chinese character in headers

Steps to reproduce:
Use Shredder to open the attachment as a "Saved Message"

When this message's overview header is fetch from the newsgroup server, Shredder can show the 'subject', but the 'from' is emtpy.

When this message is opened as saved message, Shredder cannot show both 'subject' and 'from'.

Comment 3

9 years ago
Yes, that's the same problem as bug 468351.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 468351
You need to log in before you can comment on or make changes to this bug.