Closed Bug 471438 Opened 11 years ago Closed 11 years ago

WHATWG Drag and drop, dropping to an element with ondrop defined navigates to location of the dropped object

Categories

(Core :: DOM: Drag & Drop, defect, P1)

1.9.1 Branch
defect

Tracking

()

RESOLVED FIXED
mozilla1.9.1

People

(Reporter: mayhemer, Assigned: enndeakin)

References

()

Details

(Keywords: fixed1.9.1)

Attachments

(1 file)

STR:
1. load the URL at this bug
2. drag one of the images at the bottom to one of the boxes
3. the image is dropped to the box 

The bug: the tab navigates to the image location

Expected:
the window/tab is not navigated to the image

The WHATWG example from the URI works in IE7 and Safari 3.2.1 as expected but not in Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1b3pre) Gecko/20081229 Shiretoko/3.1b3pre ID:20081229020258

I didn't test with Shiretoko on windows or linux. I did try to remove the preventDefault call from the drop handler, behavior is unchanged in Safari (still correct) nor in Firefox (still buggy).
Flags: blocking1.9.1?
The Firefox frontend has its own code for handling dropped links for some reason, so make sure to check if the event has been cancelled.
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
Attachment #354721 - Flags: review?(mano)
Confirming this patch works as I would expect.
Whiteboard: [has patch][needs review mano]
Flags: blocking1.9.1? → blocking1.9.1+
Priority: -- → P1
Comment on attachment 354721 [details] [diff] [review]
don't drop links if already handled

r=me
Attachment #354721 - Flags: review?(mano) → review+
Duplicate of this bug: 459334
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Whiteboard: [has patch][needs review mano]
OS: Mac OS X → All
Hardware: x86 → All
Whiteboard: [needs 1.9.1 landing]
Any reason why this hasn't landed on 191?
Echo:  Any reason why this hasn't landed on 1.9.1?

If it's because Neil is away until the 8th, can someone else land?
I can do that.
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/398de0eecb2d
Keywords: fixed1.9.1
Whiteboard: [needs 1.9.1 landing]
Target Milestone: --- → mozilla1.9.1
You need to log in before you can comment on or make changes to this bug.