Deleting email from separate message window, automatically opens next email

RESOLVED DUPLICATE of bug 274628

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 274628
10 years ago
10 years ago

People

(Reporter: dmflad, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.5) Gecko/2008121621 Ubuntu/8.04 (hardy) Firefox/3.0.5
Build Identifier: version 2.0.0.18 (20081125)

I do not use the message pane in Thunderbird since I want to control what emails I open and when.

-I click on an email and it opens in new window so I may read it. Okay so far.
-I delete this just read email and it drops into the trash .. this is okay too
-BUT in its place the window opens the next email in my queue.. this is NOT okay.

I have not been able to find GUI way to drop back to main Thunderbird window after deleting a just read/opened email. I want to control what email I open and when so I can toss out spam or likely nasties BEFORE they open in message pane.

Can this be done by modding some config file somewhere?

Reproducible: Always

Steps to Reproduce:
1.I click on an email and it opens in new window so I may read it. Okay so far.
2.I delete this just read email and it drops into the trash .. this is okay too
3.Now in its place the window opens the next email in my queue with me having opportunity to have it NOT open.. this is NOT okay.
Actual Results:  
I am left looking at the next email in my queue, regardless whether its older already read message or new open I really want to delete without opening it, or a new email I do want to read.

Expected Results:  
Expectation is that I open and read an email and upon deleting at the message panel I end up back at the main TB screen, ready to pick next email from listing that I want to read.

Originally filed with Launchpad as Bug 311827 but was directed to file it in bugzilla.

Comment 1

10 years ago
Can you confirm that:
- you have hidden the message preview pane
- you double click to open the first message
- when you delete the first message, the next message opens in the SAME window (not the message panel?)

But yes I see the same thing.
This doesn't seem right, though it could be by design (?)
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

10 years ago
Yes, message preview pane is hidden
Yes, use double-click to open first message
Yes, clicking "delete" button in first message makes it go away and next email appears in its place. Window contents change but window size remains same.

To get back to message panel I need to click on the some part of the message panel or its tag to get it in focus.

Comment 3

10 years ago
OK, clear. Summary updated to be clearer.
Now just need someone to fix it ...
Summary: deleting opened email automatically opens next email in message panel → Deleting email from separate message window, automatically opens next email
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 274628
You need to log in before you can comment on or make changes to this bug.