Games are slow and jerky

RESOLVED INCOMPLETE

Status

()

Core
General
--
major
RESOLVED INCOMPLETE
9 years ago
6 years ago

People

(Reporter: Six, Unassigned)

Tracking

({perf})

1.9.0 Branch
All
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_4_11; en) AppleWebKit/525.27.1 (KHTML, like Gecko) Version/3.2.1 Safari/525.27.1
Build Identifier: Version 2.0b1 (1.9.0.6pre 2008121820)

The games on both this site are slow and jerky with a stuttering quality to them.  graphics are NOT smooth.  Same can be said for the shockwave games I have played at other sites as well as the flash games.  reproducible.  adultswim.com tried to play the candy mountain massacre, couldn't get it to start with camino, safari works fine.  Pogo.com.  graphics drag and skip on nearly all the games.  funny-games.biz  same story with their flash games  works in safari, not in camino OR firefox.  The only example I can find where camino and forefox work better, is iminlikewithyou.com, which works for awhile before becoming lagged and jumpy, but the site wont work at all in safari.

Reproducible: Always

Steps to Reproduce:
1.load a game
2.try and play
3.fail
Actual Results:  
i got frustrated and opened safari to play.  despite my love of fireox, and how much i dig the new camino, i still have to keep safari on my 'puter so i can play games online.  neither of them works well.

Expected Results:  
performed smoothly.  be a great start....

no theme installed, nothing special about my MacBookPro, primarily used as a gaming machine online.  I'd much prefer to use camino or firefox than safari.  I'd say that failures in running flash, shockwave or java should be considered serious at the least considering the regularity in which they appear as major devices used by developers.

Comment 1

9 years ago
Since the comments refer to both Camino and Firefox, -> Core for triage
Component: Plug-ins → General
Product: Camino → Core
QA Contact: plugins → general
Version: unspecified → 1.9.0 Branch

Comment 2

8 years ago
I also get this problem in SeaMonkey 2.0.10 (and some recent versions) on Windows XP, SP3, which also supports the core theory. 

In the Shockwave Flash game "Bubble Trouble" on Miniclip.com, I frequently get skipped frames, occasionally resulting in missed keystrokes.

I tested SeaMonkey in safe mode and got the same problems as in regular mode. No issues in IE8.

- RG>

Comment 3

6 years ago
do you see this with current versions started in safe mode?
Keywords: perf
Whiteboard: [closeme 2012-04-15]

Comment 4

6 years ago
Closed per Whiteboard
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Whiteboard: [closeme 2012-04-15]

Updated

6 years ago
Resolution: WORKSFORME → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.