Unable to record user actions in other Thunderbird windows

RESOLVED DUPLICATE of bug 479311

Status

--
major
RESOLVED DUPLICATE of bug 479311
10 years ago
2 years ago

People

(Reporter: gkw, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
I am unable to record user actions in other Thunderbird windows, so basically when I open up the Message Compose window, focus on it, then turn on inspection intending to inspect user actions on the message compose window, I jump back to mail3pane instead.

Comment 1

10 years ago
I updated the inspector code to not automatically jump focus to the last window it binds to, leaving this to the user in order to avoid this problem from occurring. This should be fixed Committed revision 250.
(Reporter)

Comment 2

10 years ago
(In reply to comment #1)
> I updated the inspector code to not automatically jump focus to the last window
> it binds to, leaving this to the user in order to avoid this problem from
> occurring. This should be fixed Committed revision 250.

Try recording a user action of closing the message compose window. Mozmill will "hang" and the window will not be closed. Stop recording and try closing again, the modal dialog of asking whether to save will appear (twice?).

It appears the modal dialog is causing problems in the recorder functionality and I'm using revision 252.

Comment 3

10 years ago
is this a dupe of bug 479311?
(In reply to comment #3)
> is this a dupe of bug 479311?

No. It is not.

Gary, are you using the correct controller when working in the new window? Can you provide a testcase?
Ok, I missed the part with the modal dialog. Lets dupe...
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 479311
(Assignee)

Updated

2 years ago
Product: Testing → Testing Graveyard
You need to log in before you can comment on or make changes to this bug.