Add reviews to user profile pages

VERIFIED FIXED in 5.0.2

Status

addons.mozilla.org Graveyard
Public Pages
--
enhancement
VERIFIED FIXED
10 years ago
3 years ago

People

(Reporter: osunick, Assigned: wenzel)

Tracking

Dependency tree / graph

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

10 years ago
This can be a simple list of addons the user has reviewed which are linked to the reviews they've written.  Ideally, it would be contain the entirety of the review content.

This is useful for two reasons- 1: it's a useful aspect of a user's profile and 2: it helps the editor team review new candidates for the editor team.

It's especially important because we're looking at ratcheting up the editor staff in January.  Thanks!
(Reporter)

Comment 1

10 years ago
Awesome mockup:

Add-ons by osunick
<addon listing>
Reviews by osunick
   <link to Delicious Bookmarks>
        Delicious is teh awesum
   <link to Firebug>
        Firebug is teh awesum

Styling can match the addon listing on user profile exactly.
(Assignee)

Comment 2

10 years ago
This is a dupe of bug 377706, but because you made such an awesome mockup, I'll go ahead and dupe that bug against this.
(Assignee)

Updated

10 years ago
Duplicate of this bug: 377706
(Assignee)

Updated

10 years ago
Depends on: 384798
(Assignee)

Updated

10 years ago
OS: Mac OS X → All
Hardware: x86 → All
Version: unspecified → 4.x
Assignee: nobody → fwenzel
Target Milestone: --- → 5.0.1
(Assignee)

Comment 4

10 years ago
Created attachment 357619 [details] [diff] [review]
add user reviews to info page

This patch adds all of a user's reviews to their info page. Do you mind reviewing this, Laura?
Attachment #357619 - Flags: review?(laura)
(Assignee)

Updated

10 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 5

10 years ago
Laura, do you have time to look at this before the code freeze or would you like me to give it to somebody else? Thanks :)
Comment on attachment 357619 [details] [diff] [review]
add user reviews to info page

I think Laura is gone for the night so I looked at it.

It works for the most part, but I've got 2 comments:

1) If the user doesn't have a first/last name it just says "Review by ".  Since we're requiring one of first/last/nick name we should use the nick name if the others are blank.

2) The links to the add-ons are using whatever product is in the URL.  I remember making a special patch to fix this for the user's add-ons list so we should be consistent here.
Attachment #357619 - Flags: review?(laura) → review-
(Assignee)

Comment 7

10 years ago
Thanks, Wil. I'll push this out of 5.0.1 as well and fix the problems you mention.
(Assignee)

Updated

10 years ago
Target Milestone: 5.0.1 → 5.0.2
(Assignee)

Comment 8

10 years ago
Created attachment 359798 [details] [diff] [review]
Adding reviews to user info page, take 2

This patch fixes the two problems you pointed out.
Attachment #357619 - Attachment is obsolete: true
Attachment #359798 - Flags: review?(clouserw)

Updated

10 years ago
Attachment #359798 - Flags: review?(clouserw) → review+
(Assignee)

Comment 9

10 years ago
All right, thanks. Checked into r21881.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Keywords: push-needed
Resolution: --- → FIXED
Verified FIXED on https://preview.addons.mozilla.org/en-US/firefox/user/235535.
Status: RESOLVED → VERIFIED
Keywords: push-needed

Updated

10 years ago
Blocks: 483147
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.