Closed Bug 471599 Opened 13 years ago Closed 13 years ago

mobile talos configs

Categories

(Release Engineering :: General, defect)

All
Maemo
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: aki, Assigned: aki)

References

()

Details

Attachments

(4 files, 3 obsolete files)

Attached file staging mobile buildbot master.cfg (obsolete) —
We need to check in the staging mobile buildbot config (attached).
Also attached is the current mobile.config I'm using on the Nokia N810s (dependent on bug 471465)
Attachment #354897 - Flags: review?(anodelman)
Attached file staging mobile buildbot master.cfg (obsolete) —
With some added tp fixes.  This probably isn't final either, but closer.  and I can submit a patch if it changes.
Attachment #354897 - Attachment is obsolete: true
Attachment #355488 - Flags: review?(anodelman)
Attachment #354897 - Flags: review?(anodelman)
Comment on attachment 355488 [details]
staging mobile buildbot master.cfg

I'd like to see the mobile factory folded into perfrunner.py, so that this can all live together.

I'm also seeing quite a bit of rewrites of functions that already exist in perfrunner.py (like the untarring step, and the wget step).  I'm aiming for as much code sharing as we can get out of this.

Ideally, the mobile factory would end up in perfrunner.py and then there could be a separate master.cfg for mobile - though we could also consider folding the whole thing into the talos production master.cfg.
Attachment #355488 - Flags: review?(anodelman) → review-
>I'd like to see the mobile factory folded into perfrunner.py, so that this can
>all live together.

Done.  I left TalosFactory alone but can further hack the objects to have more shared code if you want me to.

>I'm also seeing quite a bit of rewrites of functions that already exist in
> perfrunner.py (like the untarring step, and the wget step).  I'm aiming for as
> much code sharing as we can get out of this.

Done.  I've left the PerfConfigurator step alone since I'm hacking that quite a bit, but as above I can work on this if you think it's important.  Knowing that I have close to a zero percent chance right now of screwing up production Talos is kind of comforting to me, though.

> Ideally, the mobile factory would end up in perfrunner.py and then there could
> be a separate master.cfg for mobile - though we could also consider folding 
> the whole thing into the talos production master.cfg.

Done.  We can't roll into the talos master.cfg unless we either punch a hole in the firewalls to allow colo VMs to control office devices or move the mobile devices to the colo... neither of which is desirable afaik.

I'm calling these "mobile" and "mobile-staging" since unit tests will also run off these buildbot masters eventually.
Attachment #355488 - Attachment is obsolete: true
Attachment #362746 - Flags: review?(anodelman)
Attachment #362746 - Attachment is obsolete: true
Attachment #362746 - Flags: review?(anodelman)
Comment on attachment 362746 [details] [diff] [review]
prod/stage master.cfg with perfrunner

obsoleted by new talos changes.
Duplicate of this bug: 471465
This patches talos/perfrunner.py, but I could also create my own until this is moved into buildbotcustom.
Attachment #371546 - Flags: review?(anodelman)
This is the talos diff, minus the new files because cvs is special that way.

mobile.config is above; adding talos/breakpad/maemo/minidump_stackwalk and fix_jit.sh shortly.
Attachment #371547 - Flags: review?(anodelman)
Attached file fix_jit.sh hack
This is my jit hack script.  Doesn't need to be checked in, as long as I copy it onto the devices.
My minidump_stackwalk, cross compiled on scratchbox, is here:
http://people.mozilla.org/~asasaki/maemo/minidump_stackwalk

Since we don't yet have symbols, this is purely academic.
Summary: staging mobile buildbot configs → mobile talos configs
No longer blocks: 455755
Attachment #371546 - Flags: review?(anodelman) → review+
Comment on attachment 371547 [details] [diff] [review]
talos patch, minus new files

The talos component of the page may have aged a bit due to recent talos check ins, but otherwise it looks good.
Attachment #371547 - Flags: review?(anodelman) → review+
Comment on attachment 371546 [details] [diff] [review]
buildbot-configs patch

Revision 1127:7cb377ca0ada

I copied perfrunner.py into mobile/ and mobile-staging/ so as not to affect talos production, even though I'm just adding two classes.  I'll switch to buildbotcustom once bug 448047 is fixed.
Attachment #371546 - Flags: checked‑in+ checked‑in+
I've created user repos.

- speed of development; mobile is on a tight schedule
- differing needs from desktop talos
- desktop talos is tightly locked down atm
- maemo might have a relatively small changeset; wince will be changing much more
- i'm constantly making changes and am worried about losing work
- jmaher and others want to run maemo talos and are currently forced to apply patches to do so

Talos checked into http://hg.mozilla.org/users/asasaki_mozilla.com/talos-maemo/ with CVS subdirectories intact so I can |cvs diff| or |cvs up| to merge in mainline talos changes.

Mobile buildbot configs (for the mini + devices) branched/checked into http://hg.mozilla.org/users/asasaki_mozilla.com/mobile-configs/ ; I can keep that or just use that as a working repo that I can merge into buildbot-configs whenever needed (with review, of course).

I'm going to resolve this fixed and remove this bug from the ever-growing list of bugs waiting for post-3.5rc1 downtime.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.