RSS messages always load remote images

RESOLVED INVALID

Status

MailNews Core
Feed Reader
RESOLVED INVALID
10 years ago
9 years ago

People

(Reporter: banda bassotti, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_6; it-it) AppleWebKit/525.27.1 (KHTML, like Gecko) Version/3.2.1 Safari/525.27.1
Build Identifier: versione 2.0.0.18 (20081105)

my preferences are set not to permit automatic download of any images,they works as expected with email

Reproducible: Always

Steps to Reproduce:
1.subscribe to any rss feed
2.set alway load page 
3.view the feed
Actual Results:  
the images are displayed

Expected Results:  
no images at all
This is as designed, RSS is not mail. The reason images are blocked in mail is because mail is addressed to a specific person. When an image is loaded it can reveal that the address is live and that the mail has been read, both of which raise privacy concerns.

Every subscriber gets the same RSS feed, however, and when images are loaded only the user's IP address is revealed to the server. This is exactly the same as when browsing a web site and there's not the same kind of privacy concerns as with mail.

The same image-blocking options built into Firefox exist behind-the-scenes in Thunderbird. You could block all images using the same pref settings if you use the advanced configuration option, but there's no easy UI to do it -- you'll need help from our support site or a user group. There are some addons that expose that kind of functionality though. Check them out at https://addons.mozilla.org/en-US/thunderbird/
Group: core-security
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID

Updated

9 years ago
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core
You need to log in before you can comment on or make changes to this bug.