Integration with keyboard shortcuts panel in System Preferences

RESOLVED DUPLICATE of bug 429824

Status

enhancement
RESOLVED DUPLICATE of bug 429824
11 years ago
11 years ago

People

(Reporter: kazar, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.0.5) Gecko/2008120121 Firefox/3.0.5
Build Identifier: version 2.0.0.19 (20081209)

Many Mac users find the ways in which Thunderbird is "un-Mac-like" a deterrent from using it, since it does not conform to Apple UI guidelines and the way users use their "real" Mac apps.

A major example of this is the fact that Thunderbird does not respect custom keyboard bindings set up for it in System Preferences. 

1. Default key combos still work even after they have been modified in System Preferences (Keyboard & Mouse panel, Keyboard Shortcuts).

I have a keyboard shortcut set up for Thunderbird's Quit menu command because "Command-Q" being so close on the keyboard to "Command-W" often results in me quitting when I meant to simply close a window. So I revised the key binding for Quit to Ctrl-Command-Q. BUT Thunderbird will still quit if I only press Command-Q.

2. Many menu commands across Thunderbird use the same text string, making it impossible to establish keyboard shortcuts in System Preferences that target one of the commands.

Example: "All" is the menu string that appears under the View top-level menu in:
- Folders
- Messages
- Threads
- Headers

If the string could be revised to be unique, such as "All Folders", "All Messages" etc., keyboard bindings in System Prefs might work.


3. At least in some instances, Mac keyboard bindings will not work until after the command is selected manually from the menus using the mouse.

Example: I have mapped "Run Junk Mail Controls on Folder" to the key combo Ctrl-J. The binding works, but ONLY after I have first used the command once by selecting from the menu with my mouse.





Reproducible: Always

Steps to Reproduce:
see Details
Actual Results:  
see details

Expected Results:  
see details
see bug 429824 comment 2
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 429824
Thanks Jo, that was fast. I did search first but in my inexperience did not find that other bug. Sorry!
Question: I only thought to search in Thunderbird bugs. Isn't a Thunderbird bug a separate thing than a Firefox bug? For example, in the FF but #429824, because it is about FF and not Tbird, there is no mention of the further complicating factor in thunderbird that many menu items have exactly the same name. The menu item names, therefore, in *thunderbird* won't be compatible with custom keyboard shortcuts even if the bug in the core (or whatever, sorry, obviously NOT a programmer) that FF and TB share is fixed.

TIA for cluing me in!
You need to log in before you can comment on or make changes to this bug.