Open Bug 471789 Opened 13 years ago Updated 3 years ago

Strange boxes created by GTK

Categories

(Core :: Widget: Gtk, defect, P5)

x86
Linux
defect

Tracking

()

UNCONFIRMED

People

(Reporter: erappleman, Unassigned)

References

()

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.5) Gecko/2008121711 Ubuntu/9.04 (jaunty) Firefox/3.0.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.5) Gecko/2008121711 Ubuntu/9.04 (jaunty) Firefox/3.0.5

Take a look at the attached picture, you will notice at the bottom of each box there is a blue rectangle dangling. I have also seen this on the GameFAQs message boards.

However, I cannot replicate on a Windows PC or on a browser other than Firefox.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Attached image Dangly parts!
Attachment #355040 - Flags: superreview?
Attachment #355040 - Flags: review+
Attachment #355040 - Flags: approval1.9.1?
Flags: blocking-firefox3.1?
Attached image More dangly parts!
Attachment #355041 - Flags: superreview?
Attachment #355041 - Flags: review+
Attachment #355041 - Flags: approval1.9.1?
Flags: blocking-firefox3.1?
Attachment #355040 - Flags: superreview?
Attachment #355040 - Flags: review+
Attachment #355040 - Flags: approval1.9.1?
Comment on attachment 355041 [details]
More dangly parts!

The various flags you set have specific meanings - please don't touch them if you are unsure of their usage!
Attachment #355041 - Flags: superreview?
Attachment #355041 - Flags: review+
Attachment #355041 - Flags: approval1.9.1?
According to zzxc on IRC, this is an Ubuntu theme engine bug.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → WORKSFORME
For the record, the GTK theme here was Shiki-Colors
Status: RESOLVED → VERIFIED
The error in question is related to the use of non-zero GtkRange::trough-border values.
Summary: Dangling CSS under certain website elements → non-zero GtkRange::trough-border value produces strange boxes in Firefox
(In reply to comment #5)
> For the record, the GTK theme here was Shiki-Colors

Specifically, the Murrine version of Shiki-Colors, not the Clearlooks version.
Summary: non-zero GtkRange::trough-border value produces strange boxes in Firefox → Strange boxes created by GTK
Component: General → Shell Integration
Update: All GTK themes that use a non-zero value are affected, regardless of engine. Crux and Glider are 2 examples that are packaged with Ubuntu. 

Testcase page: https://bugzilla.mozilla.org/show_bug.cgi?id=471789

Be sure to refresh the page and look at the CC list box.
Version: unspecified → Trunk
Duplicate of this bug: 500368
I'd appreciate it if you didn't close my bugs before I get a chance to further explain them.

Also, I can't reopen the other bug, it won't let me.

Furthermore, the Murrine dev/creator says this bug is not GTK or Murrine's bug, it's a Firefox bug.
Status: VERIFIED → UNCONFIRMED
Resolution: WORKSFORME → ---
Component: Shell Integration → Widget: Gtk
Product: Firefox → Core
QA Contact: general → gtk
Eric -- you've marked bug 500368 as fixed.  Does that mean this bug is fixed, too?  (I'm unclear from comment 10 whether this bug and bug 500368 are actually duplicates or not -- it looks like they are, but in comment 10 / bug 500368 comment 2, you strongly objected to their being linked as duplicates for some reason.)
You need to log in before you can comment on or make changes to this bug.