Closed Bug 471792 Opened 11 years ago Closed 10 years ago

xpcshell-tests: test_privatebrowsingwrapper_removeDataFromDomain.js and test_removeDataFromDomain.js intermittently leak a few nsLocalFile + nsStringBuffer

Categories

(Firefox :: Private Browsing, defect)

x86
All
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: sgautherie, Unassigned)

References

Details

(Keywords: intermittent-failure, memory-leak)

Attachments

(1 file)

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090101 Minefield/3.2a1pre] (home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/e807ec425ad7)

I ran |make check| 3 times,
and the second time (only) I got a leak,
which I had never seen before.
Could you try to reduce this by removing tests from test_removeDataFromDomain.js to see exactly which piece of code is the culprit?
I tried to reproduce by running it |SOLO_FILE=| a few times, but could not.

I filed this bug in case it happens again on my local,
or after bug 569523 is fixed.
(In reply to comment #3)
> or after bug 569523 is fixed.

Bug 469523 !
I tried running the tests ~20 times on a debug build with memleak detection support turned on, but didn't see this leak at all.
It would be nice to see if other people can reproduce this.
Keywords: qawanted
Resolving WFM, if there's a real STR to be found, please report it then.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
V.WFM, it never happened again :-/
Status: RESOLVED → VERIFIED
Keywords: qawanted
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090402 Minefield/3.6a1pre] (home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/c4f6bb1db611)

Ftr,
while testing my patch for bug 384339, I got once
{
test_privatebrowsing\unit\test_privatebrowsingwrapper_removeDataFromDomain.js

2 nsLocalFile + 2 nsStringBuffer
}
running the whole xpcshell-tests suite.
But I was enable to reproduce it running only this test.
Ftr, a Linux build I checked on 2009.04.09 had it on its 'check' run (only?).

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1240742535.1240748437.9461.gz&fulltext=1
Linux mozilla-central unit test on 2009/04/26 03:42:15
'check' only.

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1240771335.1240778234.25540.gz&fulltext=1
Linux mozilla-central unit test on 2009/04/26 11:42:15
None.

Intermittent!
Blocks: 438871
Status: VERIFIED → UNCONFIRMED
Flags: wanted-firefox3.6?
OS: Windows 2000 → All
Resolution: WORKSFORME → ---
Whiteboard: [orange]
What now? V.Fixed -> New was not possible :-(
Status: UNCONFIRMED → NEW
Ever confirmed: true
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.5/1241536379.1241540553.1631.gz&fulltext=1
Linux mozilla-1.9.1 unit test on 2009/05/05 08:12:59

Leaked 3 + 3.
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.5/1246880126.1246884253.1313.gz&fulltext=1
Linux mozilla-1.9.1 unit test on 2009/07/06 04:35:26
Leaked 1 + 1.
And test_privatebrowsingwrapper_removeDataFromDomain.js leaked 3 + 3.

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.5/1246880129.1246884688.5893.gz&fulltext=1
WINNT 5.2 mozilla-1.9.1 unit test on 2009/07/06 04:35:29
Leaked 2 + 3.
Summary: test_removeDataFromDomain.js intermittently leaks 4 nsLocalFile + 4 nsStringBuffer → test_privatebrowsingwrapper_removeDataFromDomain.js and test_removeDataFromDomain.js intermittently leak a few nsLocalFile + nsStringBuffer
Duplicate of this bug: 490251
Summary: test_privatebrowsingwrapper_removeDataFromDomain.js and test_removeDataFromDomain.js intermittently leak a few nsLocalFile + nsStringBuffer → xpcshell-tests: test_privatebrowsingwrapper_removeDataFromDomain.js and test_removeDataFromDomain.js intermittently leak a few nsLocalFile + nsStringBuffer
This has not been reported in the Tinderboxen for a long time.  Resolving as WFM.  Please reopen if it's seen again.
Status: NEW → RESOLVED
Closed: 11 years ago10 years ago
Resolution: --- → WORKSFORME
Flags: wanted-firefox3.6?
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.