jsgc.obj : error LNK2019: unresolved external symbol _posix_memalign referenced in function _NewGCChunk

RESOLVED DUPLICATE of bug 429745

Status

()

RESOLVED DUPLICATE of bug 429745
10 years ago
9 years ago

People

(Reporter: dmda, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 2.0.50727; .NET CLR 1.1.4322)
Build Identifier: 1.9.0.5

failed to compile debug-version with jemalloc turned on. 
Note: it expects posix_memalign with leading underscore, while dll exports this symbol without underscrore.

Non-debug build works fine.

Reproducible: Always

Steps to Reproduce:
have vc2005 (non-express), vista sdk, setup-1.3, run start-msvc8.bat
use the following config file:

mk_add_options MOZ_CO_PROJECT=browser
ac_add_options --enable-application=browser


ac_add_options --enable-debug
ac_add_options --enable-libxul
ac_add_options --disable-logging
ac_add_options --disable-strip
ac_add_options --disable-optimize
ac_add_options --enable-jemalloc

ac_add_options --disable-tests
ac_add_options --enable-crypto
ac_add_options --enable-mathml
ac_add_options --disable-mailnews
ac_add_options --disable-ldap
ac_add_options --disable-installer

Actual Results:  
-

Expected Results:  
-

looks very similar to Bug 422185 but it appeared completely different.

As far as I see the problem happens because mozcrt19 (the CRT replacement) is compiled without debug info (-O2 -DNDEBUG etc), while js (and all the other libs) are to be comipled with 
-MDd and -D_DEBUG 

It won't do.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 429745
You need to log in before you can comment on or make changes to this bug.