more than one 'Most Visisted' tabs in toolbar when importing bookmarks.html created by autoExportHTML

VERIFIED FIXED in Firefox 3.6a1

Status

()

defect
VERIFIED FIXED
11 years ago
10 years ago

People

(Reporter: chprakashs, Assigned: mak)

Tracking

({verified1.9.1})

3.0 Branch
Firefox 3.6a1
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3 (.NET CLR 3.0.4506.2152)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3 (.NET CLR 3.0.4506.2152)

I'm using user_pref("browser.places.importBookmarksHTML", true); and user_pref("browser.bookmarks.autoExportHTML", true); settings and these are set forcefully everytime on windows logon to achieve something (Explained in http://forums.mozillazine.org/viewtopic.php?f=38&t=896955)

Problem:
First launch of firefox after upgrade is creating 'Most visited' tab in toolbar and only shutdown of firefox thos changes are exported to bookmark.html. On next launch of Firefox it tries to import bookmarks from bookmarks.html (I'm setting import setting to true and deleting .json files)  and its creating two tabs of 'Most Visited'. I guess this places.sqlite which stores bookmarks is holding one default tab and the one in bookmarks.html is getting added to it. 

I'm using logon script to delete json file and set import setting to true. Everytime a winodws logon is done and firefox is started one extra tab is getting added. Same is the case with "Recently Bookmarked" and "Recent Tags".

Please let me know if there is quick workaround for this problem. I planned to deploy firefox to few users in our organization tomorrow and then suddenly stuck up with this problem.

Thanks,
Prakash


Reproducible: Always

Steps to Reproduce:
1. first launch of firefox after upgrade and close firefox
2. set import bookmarks setting to 'true', delete .json files (bookmarks backup)
3. launch firefox and it gives two 'most visited' tabs 
4. extra tab gets added each time you do the same
setting browser.places.smartBookmarksVersion to -1 will disable smart bookmarks creation
Summary: more than one 'Most Visisted' tabs in toolbar → more than one 'Most Visisted' tabs in toolbar when importing bookmarks.html created by autoExportHTML
It doesn't seem to be working. 

I've set 
user_pref("browser.bookmarks.autoExportHTML", true);
user_pref("browser.places.importBookmarksHTML", true);
user_pref("browser.places.smartBookmarksVersion", -1);

even tried
user_pref("extensions.tabmix.checkIfBookmarkTabExists", true);

but the problem explained in #1 persists.
we should probably detect if autoExport is set and disable smart bookmarks by ourselves, and avoid to overwrite the pref if it is set to -1.
I'm confirming the bug.
Status: UNCONFIRMED → NEW
Ever confirmed: true
any other workaround? If not, I will have to leave importBookmarksHTML setting to false (shouldn't force change to true) after first launch so that multiple tabs are not created due to import. But that doesn't serve my purpose explained in http://forums.mozillazine.org/viewtopic.php?f=38&t=896955.
browser.places.smartBookmarksVersion is overwritten with 0 if we are about to import from bookmarks.html, so atm i can't see a workaround.
Target Milestone: --- → Firefox 3.1
Posted patch patch v1.0Splinter Review
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Attachment #356175 - Flags: review?(dietrich)
Comment on attachment 356175 [details] [diff] [review]
patch v1.0

r=me
Attachment #356175 - Flags: review?(dietrich) → review+
http://hg.mozilla.org/mozilla-central/rev/ccd12ae3f34d
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: Firefox 3.1 → Firefox 3.2a1
Comment on attachment 356175 [details] [diff] [review]
patch v1.0

asking approval for 1.9.1, this is needed to allow users to disable smart bookmarks (for someone a privacy concern). low risk
Attachment #356175 - Flags: approval1.9.1?
Hello people,

Even if this fixed, should I upgrade to the latest version or can this be integrated in the version I'm using now (3.0.3)?
After this is fixed can I use and import and export bookmarks settings with the smart bookmarks getting duplicated?
hello guys, could someone please answer this?
this "could" get into 3.1 if approved, not in 3.0.x, sorry i don't understand the second question...
this is wanted imo, since in some case we could create smart bookmarks at every browser start, polluting bookmarks menu and the toolbar. And there's no workaround
Flags: wanted-firefox3.1?
oh i forgot this has already a test on trunk, that is currently disabled on branch due the lack of this approval, so when pushing to trunk remember to enable the test in test_browserGlue_prefs.js
Flags: in-testsuite+
s/when pushing to trunk/when pushing to branch/
Comment on attachment 356175 [details] [diff] [review]
patch v1.0

a191=beltzner
Attachment #356175 - Flags: approval1.9.1? → approval1.9.1+
Verified fixed on trunk and 1.9.1 based on passed unit tests.
Status: RESOLVED → VERIFIED
Component: Bookmarks & History → Places
OS: Windows XP → All
QA Contact: bookmarks → places
Hardware: x86 → All
Version: unspecified → 3.0 Branch
Duplicate of this bug: 490731
Flags: wanted-firefox3.5?
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.