Hourly tinderbox builds of 1.9.1 branch contain Shiretoko and Minefield

VERIFIED FIXED

Status

P2
normal
VERIFIED FIXED
10 years ago
5 years ago

People

(Reporter: whimboo, Assigned: nthomas)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
The hourly tinderbox builds of the 1.9.1 branch contain both Shiretoko and Minefield inside the dmg image.

http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-1.9.1-macosx/1230912228/

Ted or Ben, does one of you know when it has been regressed or which config change has caused this failure in packaging?
Repro'd. Its also happening in all mac incremental builds from 1230912228 onwards.

Interesting that this first happens in 1230912228. I went back and checked previous builds, from the oldest available incremental build still available:
http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-1.9.1-macosx/1230833028/
...until just before 1230912228
http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-1.9.1-macosx/1230907874/
...and they were all ok.


From irc with ted, no config changes happened in that time frame. Reassigning to RelEng in case a clobber on the mac slaves might help?
Component: Build Config → Release Engineering
Product: Core → mozilla.org
QA Contact: build-config → release
Version: 1.9.1 Branch → other
(Assignee)

Comment 2

10 years ago
10 of the 26 builds in the last day are 34M instead of 17M in size, randomly distributed, so this seems likely to be 2 of the 5 slaves rather than a code change.
Assignee: nobody → nthomas
Priority: -- → P2
(Assignee)

Comment 3

10 years ago
According to the build log, the dir we package into the dmg is <objdir>/ppc/dist/universal/firefox

$ for host in bm-xserve1{6,7,8,9} moz2-darwin9-slave02; do echo $host: `sshc $host ls /builds/moz2_slave/mozilla-1.9.1-macosx/build/obj-firefox/ppc/dist/universal/firefox`; done
bm-xserve16: Minefield.app Shiretoko.app
bm-xserve17: Shiretoko.app
bm-xserve18: Shiretoko.app
bm-xserve19: Minefield.app Shiretoko.app
moz2-darwin9-slave02: Shiretoko.app

I'm going to clobber the obj-firefox/ on bm-xserve16 and 19.
(Assignee)

Comment 4

10 years ago
Done, leaving open for verification (via file sizes after a day).
Status: NEW → ASSIGNED
(Assignee)

Comment 5

10 years ago
Looks fine now in /pub/mozilla.org/firefox/tinderbox-builds/mozilla-1.9.1-macosx. 

Ted, do you think it's worth blowing away ppc/dist/universal each run, since that'd help for any files removed as well as app name changes. Or will that be rapidly superceded by your work to add an manifest based approach for mac packaging ?
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

10 years ago
Looks good. Thanks Nick.
Status: RESOLVED → VERIFIED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.