Software update leaves build with "wrong platform type"

RESOLVED INCOMPLETE

Status

Camino Graveyard
General
--
major
RESOLVED INCOMPLETE
9 years ago
7 years ago

People

(Reporter: Jo Rhett, Unassigned)

Tracking

Details

(Whiteboard: [CLOSEME - 4/5])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9.0.5) Gecko/2008120121 Firefox/3.0.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9.0.5) Gecko/2008120121 Firefox/3.0.5

I got a prompt to update Camino to the latest version.  I said yes, it downloaded the new version and gave me the button to Install and Relaunch.  When I did, the relaunch didn't happen. When I tried to start it, it said it was the wrong platform type.



Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

9 years ago
Did you actually try to reproduce this and had it happen again, or did you just hit "Always" by accident?
This sounds like the update failed, since we don't ship single-arch Camino or updates.

What version of Camino were you updating from?  (When you have to file a bug using another browser because Camino won't work, please do provide information about the version of Camino you were using.)

If you Get Info on the non-launching Camino in the Finder, does it report the right file size and Universal?

Do you see any messages in the Console from Camino (or perhaps Sparkle) from around the time of the update?
Summary: Version update swapped from PowerPC to Intel platform! → Software update leaves build with "wrong platform type"
https://answers.launchpad.net/sparkle/+question/62293 shows at least one other vendor has seen this, but he's no closer to any useful information that we are :(
Jo, can you please respond to comment 1 and comment 2?
Whiteboard: [CLOSEME - 4/5]
Without any additional information, I don't think we can do anything here, unfortunately, so closing this Incomplete.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 6

9 years ago
"Without any additional information, I don't think we can do anything here"

What additional information is required?  I'm sorry, I ignored the request for a version since it was clearly the version which had just come out and notified everyone to update.  Next time I'll update it to say exactly that.

Second, yes -- the update clearly failed.  Checking the file size when I downloaded the package again it was clearly less than 1/10th the size it was supposed to be.

The bug fix is obvious -- the updater should test to ensure the download was complete.
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
(In reply to comment #6)
> What additional information is required?

(In reply to comment #2)
> If you Get Info on the non-launching Camino in the Finder, does it report the
> right file size and Universal?
> 
> Do you see any messages in the Console from Camino (or perhaps Sparkle) from
> around the time of the update?

Have you had this problem again, i.e. with 1.6.7?

Comment 8

9 years ago
(In reply to comment #6)
> I ignored the request for a version since it was clearly the version
> which had just come out and notified everyone to update.

The question is what version you were updating *from*, not trying to update to.

Also, in addition to the questions Smokey quoted just above, we still would like an answer to the question in comment 1.

(In reply to comment #6)
> The bug fix is obvious -- the updater should test to ensure the download was
> complete.

It does. The dmg is checked against a signature that is sent with the update information.
(Reporter)

Comment 9

9 years ago
Smokey, I get that you are trying to be helpful but why did you ask me about
the file size when my reply clearly said "less than 1/10th the size it was
supposed to be" ?

And "messages in the Console" ?  Huh?

And seriously, do you realize that half the questions asked here weren't
possible?  Without a functioning Camino, I can't try it again.  I can't check
the Camino console... etc etc.  I had to delete the app and reinstall fresh.
(Reporter)

Comment 10

9 years ago
> The question is what version you were updating *from*, not trying to update to.

Since this was a beta release, it was the previous beta... the one which was obsoleted on the day of the report.

> Also, in addition to the questions Smokey quoted just above, we still would
> like an answer to the question in comment 1.

How does one try again without a functioning version of Camino?  I mean seriously.

And where are we going with these questions?  The problem is very clear -- the uploader needs to check the file size.  How hard is that to replicate?  What other questions do you have, really?

And for this:
> The dmg is checked against a signature that is sent with the update
information.

Is that a new fix?  Because I can assure you that the image in my Downloads folder was like 1mb in size.  The downloaded image I got using Netscape was like 15mb.
(Reporter)

Comment 11

9 years ago
Heh, okay this is funny.  Apparently not deleting your Trash can help a lot:

Name: Camino-2.0b1.dmg
Kind: Disk Image
Size: 1.9 MB on disk
Created: 1/2/09 3:43 PM
Modified: 1/2/09 3:56 PM

By comparison the working image I downloaded using Netscape said:

Size: 15.4 MB on disk
(Reporter)

Comment 12

9 years ago
I tried to upload the image, but it wouldn't let me due to a 1mb file size restriction.  You can get the image and see it for yourself from 

http://support.netconsonance.com/Camino-2.0b1.dmg

Comment 13

9 years ago
(In reply to comment #10)
> Since this was a beta release, it was the previous beta... the one which was
> obsoleted on the day of the report.

You didn't say you were using a beta; we can't intuit whether a user is running a release build or a nightly or an official beta if we aren't given any information.

(In reply to comment #9)
> And seriously, do you realize that half the questions asked here weren't
> possible?

The questions were:
- Did you actually try to reproduce this, or was your original claim of "Reproducible: Always" a mistake. It's a yes or no question, not an instruction to reproduce it.
- What version of Camino were you using before trying to update
- What is the reported size
- Does the (OS) console list any errors

None of those questions are impossible to answer. In the future, if you need clarification about questions asked in bugs, please ask for clarification; just ignoring our questions because you aren't sure what's involved or don't believe that we actually need the information doesn't help anyone.

> And where are we going with these questions?

We are trying to get information about the problem. Treating our attempts to get the information we need to debug as an adversarial game just makes the whole process more difficult. If we ask questions, it's because we believe the answers may be useful.

> The problem is very clear -- the uploader needs to check the file size.

For those of us who have read the code involved, that's less clear. If you know more about Sparkle than we do then by all means attach a patch, but if not then we need to get specific information.

> How hard is that to replicate?

Nobody else has ever reported this problem to us in all the updates we've ever done, so apparently pretty hard.

(In reply to comment #11)
> Name: Camino-2.0b1.dmg
> Kind: Disk Image
> Size: 1.9 MB on disk

If you take that out of the trash, will the OS even mount it?
(Reporter)

Comment 14

9 years ago
> You didn't say you were using a beta; we can't intuit whether a user is running
> a release build or a nightly or an official beta if we aren't given any
> information.

I understand what you mean, but nightlys don't have "new version available, please update" every day do they?  And how many beta or release updates are there?  I seriously doubt this would have been difficult to determine.

> None of those questions are impossible to answer. In the future, if you need
> clarification about questions asked in bugs, please ask for clarification; just
> ignoring our questions because you aren't sure what's involved or don't believe
> that we actually need the information doesn't help anyone.
...
> Treating our attempts to get the information we need to debug as an 
> adversarial game just makes the whole process more difficult.
> If we ask questions, it's because we believe the answers may be useful.

They were ignored because they fell into a list of "things to do" which is overlong, and what appears to be "busy work" queries don't tend to stay in my mind so I forgot about them.

> If you take that out of the trash, will the OS even mount it?

No, it produces the error message I reported in the opening of this ticket "wrong platform type"

Comment 15

9 years ago
(In reply to comment #14)
> I understand what you mean, but nightlys don't have "new version available,
> please update" every day do they?  And how many beta or release updates are
> there?  I seriously doubt this would have been difficult to determine.

Release builds update to other release builds. Betas update to the latest beta. Alphas update to the latest beta. Nightlies update to the latest beta. Users can run software update on any of those builds at any time. You could have been using any of literally hundreds of different builds, and updating to one of two different builds.

> They were ignored because they fell into a list of "things to do" which is
> overlong, and what appears to be "busy work" queries don't tend to stay in my
> mind so I forgot about them.

Well, we can't debug problems if we can't get answers to questions. I'm not sure why you think we would waste our time asking questions if we didn't want the answers to them, but that's not the case.

If someone more willing to work with us on debugging ever encounters this (in something more recent than a1, since we've updated Sparkle since then), feel free to re-CC me.
If you ever see this again and will have time to answer questions, please reopen this bug.  There's nothing more we can do with the current information, so resolving INCOMPLETE.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → INCOMPLETE

Updated

8 years ago
Duplicate of this bug: 502257
Duplicate of this bug: 440424
You need to log in before you can comment on or make changes to this bug.