Crashes in pop-up sidebar when "verio" advertisement banner comes up

VERIFIED WORKSFORME

Status

SeaMonkey
General
P1
critical
VERIFIED WORKSFORME
18 years ago
14 years ago

People

(Reporter: Alek Jeziorek, Assigned: ruslan)

Tracking

({smoketest})

Trunk
x86
Windows 98
smoketest

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2-])

(Reporter)

Description

18 years ago
-start browser
-Tasks|Instant Messenger
-in the pop-up there will be a banner at the bottom
-Wait till it changes to the verio banner
-It will crash
-reproducible all the time on branch m17 build 2000-08-01-04-M17
(Reporter)

Updated

18 years ago
Keywords: smoketest
(Reporter)

Comment 1

18 years ago
here's the stack:
   
   0x00000411 
                                         
     
   nsCOMPtr_base::~nsCOMPtr_base 
                                        
[d:\builds\seamonkey\mozilla\xpcom\base\nsCOMPtr.cpp, line 50]
     
   nsHTTPChannel::~nsHTTPChannel 
                                        
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHTTPChannel.cpp, line 
154]
     
   nsHTTPChannel::Release 
                                        
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHTTPChannel.cpp, line 
154]
     
   nsCOMPtr_base::~nsCOMPtr_base 
                                        
[d:\builds\seamonkey\mozilla\xpcom\base\nsCOMPtr.cpp, line 50]
     
   nsDocLoaderImpl::DocLoaderIsEmpty 
                                        
[d:\builds\seamonkey\mozilla\uriloader\base\nsDocLoader.cpp, line 621]
     
   nsDocLoaderImpl::OnStopRequest 
                                        
[d:\builds\seamonkey\mozilla\uriloader\base\nsDocLoader.cpp, line 545]
     
   nsLoadGroup::RemoveChannel 
                                        
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsLoadGroup.cpp, line 552]
     
   nsHTTPChannel::ResponseCompleted 
                                        
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHTTPChannel.cpp, line 
1800]
     
   nsHTTPServerListener::OnStopRequest 
                                        
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHTTPResponseListener.cp
p, line 720]
     
   nsOnStopRequestEvent::HandleEvent 
                                        
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsAsyncStreamListener.cpp, line 
302]
     
   nsStreamListenerEvent::HandlePLEvent 
                                        
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsAsyncStreamListener.cpp, line 
106]
     
   PL_HandleEvent 
                                        
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 588]
     
   PL_ProcessPendingEvents 
                                        
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 547]
     
   _md_EventReceiverProc 
                                        
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 1045]
     
   KERNEL32.DLL + 0x363b (0xbff7363b) 
                                         
     
   KERNEL32.DLL + 0x24407 (0xbff94407) 
                                         
     
   0x00688b42 

Comment 2

18 years ago
Putting on [nsbeta2+] radar.
Whiteboard: [nsbeta2+]

Comment 3

18 years ago
vishy...what do you think of this one?

scalkins/lchiang...can you reproduce this with Branch?  Win only?
Assignee: asa → vishy
QA Contact: doronr → scalkins

Comment 4

18 years ago
Adding shrir to cc snce sidebar related.
(Reporter)

Updated

18 years ago
OS: Windows 98 → Linux
(Reporter)

Updated

18 years ago
OS: Linux → Windows 98

Comment 5

18 years ago
I saw this on Alek's 98...but cannot reproduce on my NT (win M17:2000080104)

Comment 6

18 years ago
I can't repro on my NT box either with M17 8/1 build

Comment 7

18 years ago
is this an AIM bug or something more widespread?

Comment 8

18 years ago
I can't reproduce it either on Win 95, build 2000073104, day before the build
Alek used to discover this problem.
Ruslan, does this ring any bell - since it seems to crash somewhere in necko 
code? thanks, Vishy. Basically looks like it crashes only in Win98 not in Win95 
or NT. 
Status: NEW → ASSIGNED
adding gagan into the cc list. 
im trying to repro on my win98 box. 
doesnt happen with this build on my win98 box. bld: 2000080104
gagan/ruslan - any idea if anything was checked into necko that can
affect this? basically the ad in IM is just the following fragment of xul:
<iframe id="ad-iframe"  src="about:blank" 
            type="content" scrolling="no"
            onclick="cmdAdClick();"/>
and periodically the following javascript is run to refresh its source
function setAdTimer()
{
  var ad_iframe = top.document.getElementById("ad-iframe");

  var adImage = aimString("app.ad.image"); 
  // this makes adImage = http://ads.web.aol.com/image/7012799/958526195/aol/
  var adTimer = aimString("app.ad.timer");

  if(ad_iframe)
    ad_iframe.setAttribute("src", adImage);
  if(window)
    window.setTimeout('setAdTimer()', adTimer);
}

Alek - can you give some more details on your Win98 box since it seems to 
only happen on your box. Memory, cpu, model.  
Severity: normal → critical
Priority: P3 → P1

Comment 13

18 years ago
ruslan should get this. 
Assignee: vishy → ruslan
Status: ASSIGNED → NEW

Comment 14

18 years ago
I'm not crashing on my Dell Latitude w/ Win98 on the aforementioned build. Will 
test on HP 4150 tonight

Comment 15

18 years ago
Using 08_01_04-M17 build on Win 98, could not reproduce crash.

Comment 16

18 years ago
Moving to [nsbeta2-]
Whiteboard: [nsbeta2+] → [nsbeta2-]
(Reporter)

Comment 17

18 years ago
i don't see this anymore on branch m17 build 2000-08-02-04-M17. i've ran through 
several different banners including verio and it did not crash marking 
worksforme
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 18

18 years ago
Marking Verified.
Status: RESOLVED → VERIFIED
Adding keyword to bugs which already show a nsbeta2 triage value in the status 
whiteboard so the queries don't get screwed up.
Keywords: nsbeta2
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.