If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

New Restore Session box is too small / not resizable

RESOLVED WORKSFORME

Status

()

Firefox
Session Restore
--
enhancement
RESOLVED WORKSFORME
9 years ago
4 years ago

People

(Reporter: David Caldwell, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090102 Shiretoko/3.1b3pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090102 Shiretoko/3.1b3pre

I generally love the new "Would you like to restore your session?" screen that comes up, but the list of windows and tabs is much too small when I have a lot of stuff open (approx 37 tiny pages worth).

Please make it fill the size of the window instead of being stuck at some fixed size...

Also related, maybe this should be a new bug, but when I have that many things open the scrollbar's thumb is really really hard to grab (Mac OS X). It's weird because it is not physically small, but it responds to clicks as if it's only a pixel or two high. Click too high or too low and it jumps up/down a page instead of grabbing and letting me scroll.

Reproducible: Always

Steps to Reproduce:
1. Open a billion windows
2. Force quit firefox.
3. Restart
Actual Results:  
Tiny list area that doesn't resize with the window.

Expected Results:  
Nice big list area that resizes with the window.
(Reporter)

Updated

9 years ago
Component: General → Session Restore
Essentially an enhancement request, although it does sound pretty useful, maybe just make the list itself expandable, ie with a little grippy in the corner?
Severity: normal → enhancement
OS: Mac OS X → All
Hardware: x86 → All

Updated

9 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → 3.1 Branch

Comment 2

9 years ago
Created attachment 362961 [details]
Restore Session in a vey large window

It would be nice for the restore session part of the page to be proportional to the size of the page.
:)

Updated

9 years ago
Duplicate of this bug: 493932
QA Contact: general → session.restore
(In reply to comment #1)
> Essentially an enhancement request, although it does sound pretty useful, maybe
> just make the list itself expandable, ie with a little grippy in the corner?

Yes, à la textboxes nowadays.

(In reply to comment #2)
> It would be nice for the restore session part of the page to be proportional to
> the size of the page.

This would also be nice.

Moving this to Trunk, since it doesn't apply to just 3.5 (which is long-dead when it comes to adding new features).
Version: 3.5 Branch → Trunk
(Reporter)

Comment 5

4 years ago
The window list box now resizes to the size of the page, so this bug is effectively fixed.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.